Dom Inspector Dom Selection Red Border not shown after manually set gfx.direct2d.force-enabled=true

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: mad_kao, Unassigned)

Tracking

21 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 753256 [details]
Blocked Graphic driver.jpg

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Blocklisting/Blocked Graphics Drivers - MozillaWiki - https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers 

My laptop has an old AMD HD 3470 graphic card as the official driver for win 8 X64 has not been updated so long. From the about:support page, I can clearly see the firefox blocked the driver versions lower than certain digits.

According to this webpage, I manually set "gfx.direct2d.force-enabled" = true. 



Actual results:

After restarting the firefox, the red border of the DOM selection from DOM inspector disappeared.  The situation is that after I clicked the " Find a node to inspect by clicking on it" from DOMI to inspect the webpage, the actual DOM selection normally should have a red zoom border. But the red rectangle disappeared. The inspect function is still functional. 



 


Expected results:

I also set other 3, 
webgl.force-enabled=true
webgl.msaa-force=true
layers.acceleration.force-enabled=true

But only gfx.direct2d.force-enabled=true has an effect on DOMI's red border.
(Reporter)

Comment 1

5 years ago
The graphic driver I choose from the sreenshot is the Win8 system default AMD driver. 

As I chose AMD official "13-1-legacy_vista_win7_win8_64_dd_ccc", 

AMD Catalyst™ Driver for AMD Radeon™ HD 4000, HD 3000 and HD 2000 Series - http://support.amd.com/us/gpudownload/windows/legacy/Pages/legacy-radeonaiw-vista64.aspx

the driver version is 8.970.100.7000, got blocked by Firefox as well. And I got the same result after manually set  "gfx.direct2d.force-enabled"=true

Comment 2

5 years ago
If Firefox blocked your driver, then it blocked it because it doesn't support it.  Forcing it to be enabled will probably result in problems like the one you're seeing.  This isn't really a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.