When pasting into the URL field in the link editor, clean up site URLs

RESOLVED DUPLICATE of bug 868003

Status

RESOLVED DUPLICATE of bug 868003
5 years ago
5 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:change])

(Reporter)

Description

5 years ago
What feature should be changed? Please provide the URL of the feature if possible.
==================================================================================
A common practice when working on MDN is to copy and paste URLs to anchors on MDN into the link editor's URL field, then hand-tidy the URL (such as to trip off "https://developer.mozilla.org" since it's unneeded). Let's add code that automatically does things like that.

We could also check for redirects when doing this, stripping off redirect queries or the like.

What problems would this solve?
===============================
This is really mostly cosmetic, I think, but may have other benefits that I'm not thinking of.

Who would use this?
===================
Site editors and contributors.

What would users see?
=====================
No visible change

What would users do? What would happen as a result?
===================================================
No change to user actions, except they wouldn't have to clean up URLs by hand anymore!

Is there anything else we should know?
======================================
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868003
You need to log in before you can comment on or make changes to this bug.