Querystrings causing 404s on marketplace-dev

VERIFIED FIXED

Status

Cloud Services
Operations: Marketplace
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: chuck, Assigned: oremj)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
As Victor noted in comment #3 of bug 872988, statistics dashboards are not loading their constituent data:

"even if the statistics page is now opened , the waiting spinning wheel is continuously displayed : http://screencast.com/t/5m65BzNrrTA

We should add a message saying "No results found" if we don't have any statistics for an app. You can use https://marketplace-dev.allizom.org/app/uplift to reproduce the issue"

This appears to be caused by 404s in XHR requests to get the statistics for the charts.

Requests on the example page cited above are to the following URLs:

https://marketplace-dev.allizom.org/app/uplift/statistics/installs-day-20130423-20130523.json?_=1369323692834
https://marketplace-dev.allizom.org/app/uplift/statistics/installs-day-20130509-20130523.json?_=1369323692836

Removing the timestamped querystrings (that are used to prevent this data from being cached by clients) 

This indicates a bug in the nginx rules used to appropriately filter requests to Zamboni and Fireplace.
(Assignee)

Updated

5 years ago
Assignee: server-ops-amo → oremj
(Assignee)

Comment 1

5 years ago
Fixed. Also committed to puppet for stage/prod/alt-dev.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

5 years ago
Thanks :oremj! Verified.
Status: RESOLVED → VERIFIED
Component: Server Operations: AMO Operations → Operations: Marketplace
Product: mozilla.org → Mozilla Services
You need to log in before you can comment on or make changes to this bug.