Drag & drop of a downloaded file copies a link to the file and not the file itself

RESOLVED DUPLICATE of bug 846765

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 846765
5 years ago
4 years ago

People

(Reporter: marco, Unassigned)

Tracking

21 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

5 years ago
If you drag & drop a downloaded file from the downloads panel to a directory, a link to the file is created.

I've noticed this behaviour on Mac, while on Linux it is working correctly (Firefox copies the file itself).

I don't know if this is by design, but shouldn't it be consistent across platforms and browsers? (Safari copies the file)
I think someone already reported this, there is some code doing the wrong thing on Mac, it should be consistent across all of the platforms.
Whiteboard: [DUPEME]
(Reporter)

Comment 2

5 years ago
(In reply to Marco Bonardo [:mak] from comment #1)
> I think someone already reported this, there is some code doing the wrong
> thing on Mac, it should be consistent across all of the platforms.

The problem is that a lot of people won't try to drag & drop anymore, after they've tried the first time and it didn't work. Maybe it'd be wise to uplift the fix, when there will be one.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 888199
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 846765
You need to log in before you can comment on or make changes to this bug.