Closed Bug 875563 Opened 7 years ago Closed 6 years ago

Video player freezes after a 3GP video finishes playing

Categories

(Firefox OS Graveyard :: Gaia::Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

Details

Seen while running inari device, using Commercial RIL:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/047b7010c99a
Gaia   09299399500b50de72cdd3b4365fc6455bbbb145
BuildID 20130523070210
Version 18.0

STR:
Follow the STR from Bug 875558 below:


1. Load 4 3GP videos from a site to the SD card - one example is: http://www.mobiles24.com/downloads/s/572139-107-omc_-_how_bizarre
2. Confirm they play fine in other players such as VLC
3. Play the video in the Video App
4. Observe that the audio track moves along but the picture stays frozen
5. When you go back into the main Preview screen, you hit Bug 875522

Expected: I could play another Video
Actual: The whole Video app is frozen - you cannot play any videos or scroll through the video list.

Workaround: Restart the video app.
May I knew your build including the patch from Bug 864230 which is landed to CAF?
Thanks.
Atleast it doesn't happen on latest nexus-4 and Master branch
Hi,

I am new to mozilla. I can solve this bug. I solve similar bugs related to my work in videoplayer at Samsung R&D. Please tell me how to get it assigned on my name and where to get code and code architecture.

Thanks.
This is a typical symptom of video buffer starvation at OMXCodec. This should be fixed already. And confirmed that the problem does not happen on current v1.3 b2g.
Marcia, can you confirm if the problem is fixed?
Flags: needinfo?(mozillamarcia.knous)
(In reply to vikrant from comment #3)
> Hi,
> 
> I am new to mozilla. I can solve this bug. I solve similar bugs related to
> my work in videoplayer at Samsung R&D. Please tell me how to get it assigned
> on my name and where to get code and code architecture.

Thanks for the offer. But this problem seems to be fixed already long time before.
(In reply to Sotaro Ikeda [:sotaro] from comment #5)
> Marcia, can you confirm if the problem is fixed?

Yes, this works fine on today's 1.3 build. resolving as WFM.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → WORKSFORME
Oops.  Typo in patch bug number.  Previous comment should belong to bug 877563.
Assignee: jkitch.bug → nobody
You need to log in before you can comment on or make changes to this bug.