crash when clicking on mail folder in messenger

VERIFIED DUPLICATE of bug 8755

Status

()

Core
JavaScript Engine
P3
normal
VERIFIED DUPLICATE of bug 8755
19 years ago
17 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: chris hofmann)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

this is from a fresh build, 10 am, june 23, rh 6.0

here's the linux stack trace:

#0  0x404a4b25 in js_SkipWhiteSpace (s=0x358001c) at jsstr.c:2270
#1  0x40477e3f in js_strtod (cx=0x81c8860, s=0x358001c, ep=0xbfffcbe4,
dp=0xbfffcbdc) at jsnum.c:637
#2  0x4047765f in js_ValueToNumber (cx=0x81c8860, v=135942348, dp=0xbfffd410) at
jsnum.c:476
#3  0x40467984 in js_Interpret (cx=0x81c8860, result=0xbfffd538) at
jsinterp.c:1851
#4  0x4045f683 in js_Invoke (cx=0x81c8860, argc=1, constructing=0) at
jsinterp.c:671
#5  0x4046dd21 in js_Interpret (cx=0x81c8860, result=0xbfffdee0) at
jsinterp.c:2215
#6  0x4045f683 in js_Invoke (cx=0x81c8860, argc=1, constructing=0) at
jsinterp.c:671
#7  0x4046dd21 in js_Interpret (cx=0x81c8860, result=0xbfffe888) at
jsinterp.c:2215
#8  0x4045f683 in js_Invoke (cx=0x81c8860, argc=1, constructing=0) at
jsinterp.c:671
#9  0x4045f9c8 in js_CallFunctionValue (cx=0x81c8860, obj=0x82ade58,
fval=137027168, argc=1, argv=0xbfffea0c, rval=0xbfffea10) at jsinterp.c:749
#10 0x404377c9 in JS_CallFunctionValue (cx=0x81c8860, obj=0x82ade58,
fval=137027168, argc=1, argv=0xbfffea0c, rval=0xbfffea10) at jsapi.c:2568
#11 0x403aefd4 in nsJSEventListener::HandleEvent (this=0x836a098,
aEvent=0x8415368) at nsJSEventListener.cpp:97
#12 0x40ccdefa in nsEventListenerManager::HandleEvent (this=0x8368678,
aPresContext=@0x80fc9b8, aEvent=0xbfffef88, aDOMEvent=0xbfffef4c, aFlags=2,
aEventStatus=@0xbffff24c) at nsEventListenerManager.cpp:569
#13 0x40a284ef in RDFElementImpl::HandleDOMEvent (this=0x8367df8,
aPresContext=@0x80fc9b8, aEvent=0xbfffef88, aDOMEvent=0xbfffef4c, aFlags=2,
aEventStatus=@0xbffff24c) at nsRDFElement.cpp:2344
#14 0x40a28531 in RDFElementImpl::HandleDOMEvent (this=0x836e000,
aPresContext=@0x80fc9b8, aEvent=0xbfffef88, aDOMEvent=0xbfffef4c, aFlags=2,
aEventStatus=@0xbffff24c) at nsRDFElement.cpp:2351
#15 0x40a28531 in RDFElementImpl::HandleDOMEvent (this=0x83739d0,
aPresContext=@0x80fc9b8, aEvent=0xbfffef88, aDOMEvent=0xbfffef4c, aFlags=2,
aEventStatus=@0xbffff24c) at nsRDFElement.cpp:2351
#16 0x40a28531 in RDFElementImpl::HandleDOMEvent (this=0x83742f0,
aPresContext=@0x80fc9b8, aEvent=0xbfffef88, aDOMEvent=0xbfffef4c, aFlags=2,
aEventStatus=@0xbffff24c) at nsRDFElement.cpp:2351
#17 0x40a28531 in RDFElementImpl::HandleDOMEvent (this=0x8374f80,
aPresContext=@0x80fc9b8, aEvent=0xbfffef88, aDOMEvent=0xbfffef4c, aFlags=2,
aEventStatus=@0xbffff24c) at nsRDFElement.cpp:2351
#18 0x40a28531 in RDFElementImpl::HandleDOMEvent (this=0x8375f70,
aPresContext=@0x80fc9b8, aEvent=0xbfffef88, aDOMEvent=0xbfffef4c, aFlags=2,
aEventStatus=@0xbffff24c) at nsRDFElement.cpp:2351
#19 0x40a28531 in RDFElementImpl::HandleDOMEvent (this=0x8376d28,
aPresContext=@0x80fc9b8, aEvent=0xbfffef88, aDOMEvent=0xbfffef4c, aFlags=1,
aEventStatus=@0xbffff24c) at nsRDFElement.cpp:2351
#20 0x40cd0887 in nsEventStateManager::CheckForAndDispatchClick (this=0x83809a8,
aPresContext=@0x80fc9b8, aEvent=0xbffff2cc, aStatus=@0xbffff24c) at
nsEventStateManager.cpp:632
#21 0x40ccf8ba in nsEventStateManager::PostHandleEvent (this=0x83809a8,
aPresContext=@0x80fc9b8, aEvent=0xbffff2cc, aTargetFrame=0x8380238,
aStatus=@0xbffff24c, aView=0x82f7ee0) at nsEventStateManager.cpp:194
#22 0x40d0be19 in PresShell::HandleEvent (this=0x82f8368, aView=0x82f7ee0,
aEvent=0xbffff2cc, aEventStatus=@0xbffff24c) at nsPresShell.cpp:2047
#23 0x41099b03 in ?? () from
/builds/seth/MOZILLA/06.23.1999/04.30/mozilla/dist/bin/libraptorview.so
#24 0x410a2ed3 in ?? () from
/builds/seth/MOZILLA/06.23.1999/04.30/mozilla/dist/bin/libraptorview.so
#25 0x41097bd4 in ?? () from
/builds/seth/MOZILLA/06.23.1999/04.30/mozilla/dist/bin/libraptorview.so
#26 0x40102892 in ?? () from
/builds/seth/MOZILLA/06.23.1999/04.30/mozilla/dist/bin/libwidgetgtk.so
#27 0x4010279c in ?? () from
/builds/seth/MOZILLA/06.23.1999/04.30/mozilla/dist/bin/libwidgetgtk.so
#28 0x40102950 in ?? () from
/builds/seth/MOZILLA/06.23.1999/04.30/mozilla/dist/bin/libwidgetgtk.so
#29 0x4010360b in ?? () from
/builds/seth/MOZILLA/06.23.1999/04.30/mozilla/dist/bin/libwidgetgtk.so
#30 0x40103dd6 in ?? () from
/builds/seth/MOZILLA/06.23.1999/04.30/mozilla/dist/bin/libwidgetgtk.so
#31 0x4063c79d in ?? () from /usr/lib/libgtk-1.2.so.0
#32 0x40604037 in ?? () from /usr/lib/libgtk-1.2.so.0
#33 0x4060352f in ?? () from /usr/lib/libgtk-1.2.so.0
#34 0x40601800 in ?? () from /usr/lib/libgtk-1.2.so.0
#35 0x406345b8 in ?? () from /usr/lib/libgtk-1.2.so.0
#36 0x405d91a2 in ?? () from /usr/lib/libgtk-1.2.so.0
#37 0x405d84da in ?? () from /usr/lib/libgtk-1.2.so.0
#38 0x4067bab2 in ?? () from /usr/lib/libgdk-1.2.so.0
#39 0x406a92c6 in ?? () from /usr/lib/libglib-1.2.so.0
#40 0x406a9801 in ?? () from /usr/lib/libglib-1.2.so.0

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
I got here first, so I'll mark this as a duplicate of mine and fix it up.

*** This bug has been marked as a duplicate of 8755 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
Verified as dup
You need to log in before you can comment on or make changes to this bug.