Tab drag to new window breaks Javascript alerts/popups

RESOLVED DUPLICATE of bug 827084

Status

()

RESOLVED DUPLICATE of bug 827084
5 years ago
5 years ago

People

(Reporter: binbugtracker, Unassigned)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

Steps to reproduce:

Reproducible: Always

Steps to Reproduce:
1: Open Firefox with two tabs (first tab is only a placeholder)
2: Open Error Console
3: In second tab, navigate to http://www.w3schools.com/js/tryit.asp?filename=tryjs_alert
4: Click the button.  Should work as expected.

5: Drag Tryit Editor tab outside of Firefox to open that tab in a new window.
6: Click the button.
7: repeat step 6 until error appears in Console


Actual results:

Errors are thrown and popup never appears.  Error is
Error: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindow.alert]  (see https://bugzilla.mozilla.org/show_bug.cgi?id=681505).  As with the bug linked here, that execution crashes.


Expected results:

No error should be thrown.  Popup should appear as expected.
(Reporter)

Comment 1

5 years ago
For additional information, see stackoverflow post: http://stackoverflow.com/questions/16726624/firefox-tab-drag-yields-javascript-alert-failure

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 827084
You need to log in before you can comment on or make changes to this bug.