[B2G][Inari][Facebook]: Changes to a Facebook account are not showing up in Contacts app after 24 hours on 3G connection

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: mlevin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: inarirun2, )

(Reporter)

Description

5 years ago
Description:
While on a 3G connection, changes made on a Facebook account do not show up after a 24 hour period, automatic sync.

Prerequisite: Have Facebook contacts in the Contacts app.

Repro Steps:
1) Manually update to Inari Build ID: 20130515070208
2) Turn off wifi and enable cellular data in Settings.
3) Browse the web to ensure cellular data connectivity.
4) Import Facebook contacts into the Contacts app.
5) On a pc or laptop log into one of the Facebook accounts that are in the Contacts app.
6) Change the main name on the Facebook account for example QA Testman, to QA Çestman, in this example.
7) Wait 24 hours and then open the Contacts app.

Actual:
Facebook name remains as QA Testman instead of changing to QA Çestman.

Expected:
After 24 hours the automatic Facebook sync should have changed the name from QA Testman to QA Çestman.

Environmental  Variables:
Commercial RIL
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f

Notes:
Repro frequency: 2/2
Test Suite Name: Facebook
UCID: owd-13752
Link to failed test case: https://moztrap.mozilla.org/results/runs/?pagenumber=1&pagesize=20&sortfield=start&sortdirection=desc&filter-name=firefox+os+1.1.0+full+-+inari&filter-case=5190
Q Analysts Test Team Priority: 3

Note: This worked on a wifi connection, but is not working on a 3G connection.
For changing the sync time, could one edit : https://mxr.mozilla.org/gaia/source/apps/communications/contacts/config.json#6 and then push it back and restart the device?
(Reporter)

Comment 2

5 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #1)
> For changing the sync time, could one edit :
> https://mxr.mozilla.org/gaia/source/apps/communications/contacts/config.
> json#6 and then push it back and restart the device?

Naoki,

Where should it be pushed back to the phone? What file location?
Hrm.  changing those numbers didn't seem to work after it's already made.
I ended up making the change in the code and compiling my own.

Now that I come to think of it, I think this is by design.  We don't want mobile data connections to waste ping/update times of FB because that would cost mobile data money.  I think I need a UX person to verify that this is the case.

Josh is this the case?
Flags: needinfo?(jcarpenter)
I'm actually not very familiar with the specifics of Facebook contacts linking and importing. Casey, do you know what the correct behavior is here? I checked out the specs from Marco but could not find a precise answer.
Flags: needinfo?(jcarpenter) → needinfo?(kyee)

Comment 5

5 years ago
FB Sync will happen over the current active connection, there is no distinction between Wifi or 3G. 

I don't know why you were able to sync over Wifi and not over 3G.

thanks
(Reporter)

Comment 6

5 years ago
(In reply to Jose M. Cantera from comment #5)
> FB Sync will happen over the current active connection, there is no
> distinction between Wifi or 3G. 
> 
> I don't know why you were able to sync over Wifi and not over 3G.
> 
> thanks

Jose, 

Can you please try to repro this bug I am observing? Try over wifi then over cellular data network. If you have the time and can do this please allow 24 hours for each test to see if FB auto sync will update the changes you have made for the tests.
Jose, do you mean mobile data connection?

In the US, 3G is not supported on these phones as of yet.  The most we have is a 2G edge connection.
Oh.  Odd.  With the partner build I am getting 3.5G HSDPA on the inari.  Please ignore my last comment.

Comment 9

5 years ago
I'm not familiar with the intended behavior here.  TEF will know.  Ayman/Raffa, can you please comment?
Flags: needinfo?(kyee) → needinfo?(aymanmaat)

Comment 10

5 years ago
FB Friends Data have to be refreshed every 24 hours, that's the behaviour

Comment 11

5 years ago
I reproduced the error with a build last month, but with the new build I think it works properly.

I've been testing in Unagi and Inari and FB contacts are updated forcing the update and it works correctly for 3G (force the update is the same operation to wait 24h)

Unagi **
gaia: ea18de8
gecko: b518de0

Inari **
Gaia: 9ba891c
Gecko: e1c1223

I performed the following steps:
1. Check that the date / time are correct (if the date is different from that configured on the server, the device will not be updated)
2. Open the Contacts app
3. Press the settings button
4. Import all contacts from FB
  - All FB contacts are imported correctly
5. Open and change FB profile picture and phone number of a contact
6. Wait 5 min
7. Open the Contacts app
8. Press the settings button
9. Press the "Update imported friends"
- Contacts are updated correctly

Tomorrow, I will repeat the test waiting 24h. You can see if you get an error by forcing the update with "adb logcat | grep GeckoConsole".

Updated

4 years ago
QA Contact: ckreinbring

Comment 12

4 years ago
requesting QA to test if this is still a valid bug and to close if it is not.
Ni? to Rafael
Flags: needinfo?(aymanmaat) → needinfo?(rafael.marquez)
Whiteboard: inarirun2 → inarirun2,

Comment 13

4 years ago
I can't reproduce this bug with:

Gecko--> f156bef
Gaia--> 3786676
Branch --> Master
Device --> Unagi
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(rafael.marquez)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.