[Contacts] The labels show wrongly in edit page.

RESOLVED FIXED

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: evanxd, Assigned: evanxd)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

Details

(Whiteboard: [LeoVB+])

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Created attachment 754050 [details]
The bug screenshot

STR:
1. Save a contact with the "Fax office" label(or other labels have two words).
2. Edit the contact.

Expect:
The label has space between the two words.

Actual:
The label has NO space between the two words.
See that in the "The bug screenshot" attachment.

Gaia version:
Current master branch and v1-train 20130524070209 build.
(Assignee)

Comment 1

5 years ago
Created attachment 754072 [details]
Point to GitHub pull request: https://github.com/mozilla-b2g/gaia/pull/9997

Hi Francisco,

It's the issue we commented in http://bugzil.la/867111#c16.
Please help me review this patch.

Thanks. :)
Attachment #754072 - Flags: review?(francisco.jordano)
Comment on attachment 754072 [details]
Point to GitHub pull request: https://github.com/mozilla-b2g/gaia/pull/9997

Hi,

sorry for the delay, was bank holidays in UK.

Just checked the code and looks good to me. Also tried and working pretty well :)

Thanks a lot!!
Attachment #754072 - Flags: review?(francisco.jordano) → review+
(Assignee)

Comment 3

5 years ago
Hi Francisco,

No problem.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

5 years ago
Wish you have nice trip. :)

Evan
(Assignee)

Comment 5

5 years ago
Hi all,

Travis showed that the patch wasn't passed by unit tests.
https://travis-ci.org/mozilla-b2g/gaia/builds/7584892

But in my local, the unit test was passed.
Or is there something I missed?
Hi Evan,

the error is related to linting in the calendar.

Please go ahead and merge the bug in master. If this is already merged please add here the commit number.

Thanks!

Updated

5 years ago
Duplicate of this bug: 893053

Comment 8

5 years ago
This is a small, self-contained fix that is low risk.  Nom'ing for leo since it was recently reported agaist v1.1 again in bug 893053.
blocking-b2g: --- → leo?
Triage- Partners would take this, leo+ing
blocking-b2g: leo? → leo+
Uplifted dd4d39651c25bc6e8e3a74456c7815df2067044c to:
v1-train: db29f3b91ed67e700322842d737a2fb687fe127b
status-b2g18: --- → fixed

Comment 11

5 years ago
Varified,fixed on Leo Mozilla RIL.

Environmental Variables
Build ID: 20130716070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/629020cf576b
Gaia: fb9362d34260771d4a00b9a0e10a6bbad397bd3b
Platform Version: 18.1
RIL Version: 01.01.00.019.158

The label has space between the two words.
status-b2g18: fixed → verified

Updated

5 years ago
Whiteboard: [LeoVB+]
v1.1.0hd: db29f3b91ed67e700322842d737a2fb687fe127b
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.