View->Threads->Unread incorrectly leaves thread flag on single unread message in a thread, tricking conversation mode into multiselection behavior and broken ui elements

REOPENED
Unassigned

Status

Thunderbird
Mail Window Front End
REOPENED
4 years ago
a year ago

People

(Reporter: Dietmar Schwertberger, Unassigned)

Tracking

17 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 754156 [details]
Bug_Thread_View.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

(I'm using the german version. Unfortunately, there's no easy way to switch to an english UI, so I'm translating the menu items etc. as good as possible...)

 - Mail folder (typically for a mailing list)
 - Menu: View: Sort by: Subject
 - Menu: View: Sort by: Grouped by Topic
 - Menu: View: Topics: Only unread messages




Actual results:

Now I have many messages in the folder.

Some threads have multiple new messages. The first message of such a thread has a filled triangle displayed which allows to collapse/expand the thread. Everything is fine with these threads. When I click a message, it's shown in the preview pane.

When a thread has only one new message, then this has an empty triangle displayed next to it. Unfortunately, clicking on the message now does not present the message in the reading pane, but it lists this and the read messages instead (just like I had selected multiple messages). This is not very useful.
Now, if I try to read the message instead by double-clicking on it, then not only one tab will open, but N tabs, where N is the number of messages in the thread. All tabs are displaying the same message. Again, not very useful. Actually, it's a pain to use Thunderbird with mailing lists.

This bug has been around since many years.


Expected results:

On clicking: the message should be displayed in the preview tab.
On double-clicking: one tab should open.

I'm not sure whether the empty triangle should be displayed at all, as this is not consistent with the display of threads with more than one message. When the triangle is displayed, an action should be connected to it...

Comment 1

2 years ago
grouped subject sort was incorrectly special, should be fixed by bug 1174832.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

a year ago
The problem is still around in 38.5.0.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 3

a year ago
Do not change bugs unless you have tested for the version the fix applies to, in this case Tb 42 or higher.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → FIXED
(Reporter)

Comment 4

a year ago
(In reply to alta88 from comment #3)
> Do not change bugs unless you have tested for the version the fix applies
> to, in this case Tb 42 or higher.
Sorry, I was not aware that it would take so long to get the fix into the current release version.
I've now upgraded to 42.0, but the bug is still there.

Regards,

Dietmar

Comment 5

a year ago
Doing Sort By subject, then Grouped By Sort, then View->Messages->Unread results in a root grouped header (the subject) with 1 unread child (the message).  The header is twisty toggleable to show the child.  This works for me as expected.  There is no action (other than toggle) available on the grouped header row, as this was not implemented correctly and broken in several uses. So I don't see any bug here (tested on Tb45).
(Reporter)

Comment 6

a year ago
Ah, OK, now that I have installed an english version I see the problem:
It's the "View -> Sort by -> Threaded" which does not work.
Unfortunately, the german version has a menu entry here which translates to "Grouped by Topic" which is too similar to "Grouped by Sort" and so this has caused the misunderstanding.

So the setting that does not work with single unread entries is:
 - View: Sort by: Subject
 - View: Sort by: Threaded
 - View: Threads: Threads with unread

Would be easier to avoid such a misunderstanding if the language could be changed in the settings instead of re-installing Thunderbird.

Regards,

Dietmar

Comment 7

a year ago
It's still not clear what you think the problem is.  Maybe it's the behavior in conversation mode on a collapsed thread; this can be changed with pref mail.operate_on_msgs_in_collapsed_threads.

There are extensions to allow easy changing of locales.
(Reporter)

Comment 8

a year ago
Created attachment 8703717 [details]
Thread with one new message; before double click
(Reporter)

Comment 9

a year ago
Created attachment 8703718 [details]
Thread with one new message; after double click
(Reporter)

Comment 10

a year ago
Created attachment 8703720 [details]
Thread with two new message
(Reporter)

Comment 11

a year ago
Have a look at the attachments 2 to 4:
#2 and 3 show the problem with a thread that has exactly one new message:
 - preview does not work; instead, the old messages are listed instead
 - so for reading the message, I have to double-click it; but this does not just open the new message; it will open N tabs if there are N old & new messages; some will be empty, some will show the new message

#4 shows a thread with two new messages:
 - preview works as expected; double-clicking does also work, but it's not needed here

Regards,

Dietmar

Comment 12

a year ago
Ok, so if you have a collapsed thread with 6 messages, one of which is unread, and the pref mail.operate_on_msgs_in_collapsed_threads set to true, a double click is intended to open all of them, not just the unread one.  This wfm and isn't a bug.  #2 looks like it has no new messages and the selected row is unread.  If the selected row were read, and there was a new/unread child, the collpased row would be underlined.

Does the blank tab only happen if there's a new (rather than unread) message in a double clicked collapsed thread's root message?  Try Tb45, repair the folder first.
(Reporter)

Comment 13

a year ago
Well, then the bug is that a thread with single new/unread message is handled like a collapsed thread, but with the second bug that it can't be expanded.
(With View -> Threads -> Unread)

Comment 14

a year ago

The bug is that View->Threads->Unread shows only unread messages (not all the thread's members, which is Threads with Unread), and leaves the thread flag on the root message if there's only one.  With the thread flag wrongly set, in conversation mode, selecting the message shows it as a conversation and double clicking opens all messages in the conversation, with some blank.  With mail.operate_on_msgs_in_collapsed_threads set to false, selection works but a broken thread twisty remains.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Summary: Threaded/Grouped View: not working if there's only one unread message in a group → View->Threads->Unread incorrectly leaves thread flag on single unread message in a thread, tricking conversation mode into multiselection behavior and broken ui elements
You need to log in before you can comment on or make changes to this bug.