Bad scrolling and page locking up Firefox

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: mdew, Unassigned)

Tracking

24 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130525 Firefox/24.0 (Nightly/Aurora)
Build ID: 20130525095943

Steps to reproduce:

Visit the page: http://linuxaria.com/howto/check-your-disk-usage-with-df-and-du?lang=en
and start scrolling


Actual results:

cpu usage jumps up and scrolling is bad 


Expected results:

Should scroll without cpu load or stuttering.
(Reporter)

Updated

5 years ago
Confirming and setting to NEW.  This jank in scrolling is also happening in the latest m-c Nightly builds. 

Win7 x64 32bit Nightly

HWA: On
AMD hd3200 video chipset, AMD Phenom II CPU quad-core.  100% CPU when scrolling down to about mid-page.

tested with Nightly from cset:
https://hg.mozilla.org/mozilla-central/rev/218785bab4bd
Status: UNCONFIRMED → NEW
Ever confirmed: true
IE 10, and latest Chrome dev version are smooth, no jank, no high CPU
FYI, I'm not seeing any issues on that page with my system and the the latest Win64 hourly (Built from http://hg.mozilla.org/mozilla-central/rev/c33931682b68).

Windows 8 Pro x64, i7-920 @ 3ghz, 24GB DDR3, 240GB SATA3 SSD, GeForce 570GTX.. HWA on, DirectWrite on..

Comment 4

5 years ago
Me too. 

Also, massive loss of images (empty boxes). Aurora not usable ever since Saturday afternoon update (EDT); also coincidentally updated flash, 3 addons, and "possibly" GEarth plugin.

http://hg.mozilla.org/releases/mozilla-aurora/rev/3a4a2ca427ba

Comment 5

5 years ago
(cont) Vista32, (A/Virus, ABP, Ghostery, NoScript) all deactivated; 2-core. IE9 less jittery.

Comment 6

5 years ago
(cont... sorry) Confirmed problems in safemode.
It was pointed out that flipping pref: gfx.content.azure.enabled to 'true' there is no scrolling issue, confirmed.. scrolling is OK with pref on, but....

Setting the pref to 'false' as the work-around for bug 812695 , MS font rendering bug with IE10 (kb267838), is causing this bug to appear.

Comment 8

5 years ago
I'm not sure about that, i have HW acceleration and azure enabled yet scrolling on http://www.reddit.com/ is very janky today.

Comment 9

5 years ago
I can see the jank if I have the smooth scrolling turned ON. Doesn't matter if HW is ON or OFF. (Win7 - Intel HD3000)

Comment 10

5 years ago
CPU charge is a little bit high during scrolling, but it's pretty smooth to scroll with HWA enabled on my side.

Comment 11

5 years ago
I saw the jank (but it's a heavy webpage). 

But due to a perfect storm of coincidentally damaging my 2 separate profiles on two FF versions, at the same time I couldn't see images anymore (resolved with backed-up profiles).
I have just checked this old report in actual version of firefox and can't reproduce this.
can you please test on your system and give a short feedback about actual status?
Flags: needinfo?(mp3geek)
(Reporter)

Comment 13

2 years ago
Safe to be marked as fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mp3geek)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.