Cannot enter ALT keybindings consecutively without releasing ALT key

VERIFIED DUPLICATE of bug 52007

Status

()

Core
Keyboard: Navigation
--
enhancement
VERIFIED DUPLICATE of bug 52007
17 years ago
16 years ago

People

(Reporter: doctor__j, Assigned: Dean Tessman)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1+) Gecko/20010622
BuildID:    2001062211

For example, you want to manage your bookmarks by opening the "Bookmarks" menu
and select "Manage Bookmarks..." command.

Using keyboard navigation only, you have to:
1. press and hold <ALT> key,
2. press and release <B> key,
3. release <Alt> key, and then:
4. press and hold <ALT> key,
5. press and release <M> key,
6. release <Alt> key,

It would speed up key nav speed by saving Steps 3 and 4.
I can do it in Windows Notepad.  Can Moz do it?
->aaronl. punt as needed.

i see this on winnt and linux [2001.06.25.xx am comm branch bits]. using dr_j's
test above, if you don't release the Alt key at step (3), you end up dismissing
the Bookmarks menu.
Assignee: alecf → aaronl
OS: Windows 98 → All
Hardware: PC → All

Comment 2

17 years ago
these should work:
<alt>;b;m
<alt>-b;m

a-b means a in conjunction w/ b.
a;b means a released before pressing b
Assignee: aaronl → dean_tessman
(Assignee)

Comment 3

17 years ago
Confused.  Is this request to have this work?

1. Press Alt.
2. Press B (Bookmarks menu opens)
3. Press M (Manage Bookmarks window opens)
4. Release Alt.

Comment 4

17 years ago
welp according to nc4 and notepad, that general feature should work :o.

reporter: imoi the two strokes i described are much easier than the one you're 
asking us to support. But this bug is fine since we should support what you're 
asking for...
Severity: normal → enhancement
(Reporter)

Comment 5

17 years ago
Well, to tell the truth, I can get to the Pref menu real fast simply by pressing
Alt-E-E.  Yeah, I'm a Pref tweaking freak...  I looooove tweaking pref.
(Assignee)

Comment 6

17 years ago
Accepting and targetting, based on my interpretation on 2001-06-25.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

16 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

16 years ago
I knew I'd seen this before...

*** This bug has been marked as a duplicate of 52007 ***
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.