Defect - Bookmark "Star" states not changing once a website has been bookmarked/unbookmarked

VERIFIED FIXED

Status

defect
P1
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: kjozwiak, Assigned: jimm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [shovel-ready] feature=Defect c=Context_app_bar u=metro_firefox_user p=1 status=verified)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
When bookmarking a website using the "Star" button in the "App Bar", the "Star" will stay as "Bookmarked" once its selected even after visiting websites that are currently NOT bookmarked. If you deselect the "Star", visiting a "Bookmarked" website will not display the "Star" as "Bookmarked".

Steps to reproduce the issue:

1) Open Firefox Metro
2) Visit http://en.wikipedia.org/wiki/Main_Page
3) Slide in the "Navigation App Bar" and select the "Star" to bookmark the website
4) Create a new Tab (you will notice that the awesome screen will have the "Star" still enabled)
5) Visit http://www.facebook.com in the new Tab (you will notice that the "Star" is still enabled)
6) Deselect the "Star" while on the Facebook page and then visit the Wikipedia website that was bookmarked earlier and you will notice that the "Star" is disabled even though the website is still "Bookmarked"

Current Behavior:

- The bookmark "Star" is not being updated accordingly. The "Star" will stay enabled even when visiting websites that are not bookmarked. When you disable the bookmark "Star", it will appear disabled even when visiting websites that are bookmarked.

Expected Behavior:

- The bookmark "Star" should only appear enabled on websites that are bookmarked and disabled on websites that are not bookmarked
QA Contact: jbecerra
Priority: -- → P1
QA Contact: jbecerra
Whiteboard: feature=Defect c=Context_app_bar u=metro_firefox_user p=0 → [shovel-ready] feature=Defect c=Context_app_bar u=metro_firefox_user p=0
QA Contact: jbecerra

Updated

6 years ago
Duplicate of this bug: 876401
This defect has already been related to Bug 831937 (Bug 831937 - Story - Add or remove a bookmark) so it won't be lost track off.
No longer blocks: 831671
(Assignee)

Comment 4

6 years ago
Taking this since it's so freaking annoying!
Assignee: nobody → jmathies
(Assignee)

Comment 5

6 years ago
Posted patch fix (obsolete) — Splinter Review
(Assignee)

Comment 6

6 years ago
Posted patch fixSplinter Review
Making this much more reliable by updating when content changes vs. visibility of the bar itself.
Attachment #756572 - Attachment is obsolete: true
Attachment #756573 - Flags: review?(netzen)
Attachment #756573 - Flags: review?(netzen) → review+
(Assignee)

Comment 7

6 years ago
Posted patch export patchSplinter Review
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Whiteboard: [shovel-ready] feature=Defect c=Context_app_bar u=metro_firefox_user p=0 → [shovel-ready] feature=Defect c=Context_app_bar u=metro_firefox_user p=1
Blocks: metrov1it8
No longer blocks: metrov1defect&change
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/28b1754105fd
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Tested on 2013-06-14 using the latest nightly

- I tested using the steps in comment #0 and now I see that the star state changes consistently. Going from a bookmarked (starred) site to an unbookmarked site, I see no star icon enabled, and vice versa.
- Tested going from a bookmarked site to another bookmarked site, and both display the star correctly.
- Tested going from one unbookmarked site to another unbookmarked site, and the star was not enabled.
- Tested going from unbookmarked to bookmarked, and again the star state was consistent.
Status: RESOLVED → VERIFIED
Whiteboard: [shovel-ready] feature=Defect c=Context_app_bar u=metro_firefox_user p=1 → [shovel-ready] feature=Defect c=Context_app_bar u=metro_firefox_user p=1 status=verified
(Reporter)

Updated

6 years ago
Depends on: 887621
(Reporter)

Comment 11

6 years ago
Went through the following "Defect" for iteration #9 testing and found another issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-26-03-11-00-mozilla-central/

- Went through the original test cases from comment 0 and found the same issue. The states are not being updated when selecting both the "Bookmark" & "Pin" icons. Created Bug 887621 and blocked this defect.
(Assignee)

Updated

6 years ago
No longer depends on: 887621
Tested on 2013-07-19 using latest nightly with steps in comment #0 and the bookmark and pin states seem to be working consistently. 

As part of iteration #10 testing, I tried opening a website, bookmarking it, pinning it, opening another tab, going to the same website, observing the bookmark and pin icons, unbookmarking and unpinning, going back to the first tab, checking the change in state the icons.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130816030205
Built from http://hg.mozilla.org/mozilla-central/rev/1ed5a88cd4d0

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment0 and got expected result.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.