If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Slide show no longer displays

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: jwatt, Unassigned)

Tracking

({regression})

Trunk
x86
Mac OS X
regression

Details

Seems like something broke:

http://www.owlfolio.org/media/2010/05/stegotorus-talk/

between 2013-02-18-03-11-06-mozilla-central and 2013-03-17-03-09-23-mozilla-central.

Comment 1

4 years ago
Error console shows:

Error: TypeError: slides[i].setUserData is not a function
Source file: http://www.owlfolio.org/media/2010/05/stegotorus-talk/r/prez.js
Line: 236


See https://developer.mozilla.org/en-US/docs/Web/API/Node.setUserData
The Node.getUserData and Node.setUserData methods are no longer available from Web contents. Element.dataset or WeakMap can be used instead. (See bug 842372)

So, maybe this is site bug.

Updated

4 years ago
Blocks: 842372
No other browser worked on this site, either.
Assignee: nobody → english-us
Component: SVG → English US
Keywords: regressionwindow-wanted
Product: Core → Tech Evangelism
Since this is a bug for multiple browsers and not Mozilla specific, I've filed an issue on webcompat.com. Closing this bug.

See: https://github.com/webcompat/web-bugs/issues/39
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
For the record, this was never tested in anything other than the specific browser I was going to use for the talk (which was whichever version of Firefox was in beta in October of 2012) and I'm not at all surprised it has broken.  (I am, however, peeved.  What was so wrong with getUserData that it had to be utterly removed?) I will eventually get around to replacing my hand-rolled presentation script with something that someone other than me maintains, but it may be a while.
> What was so wrong with getUserData that it had to be utterly removed

The spec was pretty insane (e.g. cloning a node subtree required calling into arbitrary user script in the middle of the clone operation, without defining what happens if that script then modifies the subtree being cloned).
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.