Closed Bug 876237 Opened 7 years ago Closed 7 years ago

E.me freezes on load

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+, b2g18 verified)

RESOLVED FIXED
1.1 QE2 (6jun)
blocking-b2g leo+
Tracking Status
b2g18 --- verified

People

(Reporter: matias, Assigned: matias)

References

()

Details

Attachments

(1 file)

localStorage is blocky.
Loading E.me freezes when there is a lot of data stored.

Need to convert to IndexedDB
Attached file redirect to PR 10004
Attachment #754220 - Flags: review?(crdlc)
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Assignee: nobody → matias
Attachment #754220 - Attachment mime type: text/plain → text/html
Comment on attachment 754220 [details]
redirect to PR 10004

Good work!!
Attachment #754220 - Flags: review?(crdlc) → review+
blocking-b2g: --- → leo?
thanks for the review Cristian, we always feel bad when sending you a huge PR to review :) hopefully this will help with performance!
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
don't worry my friend!
blocking-b2g: leo? → leo+
Target Milestone: --- → 1.1 QE2 (6jun)
Keywords: checkin-needed
(In reply to Ran Ben Aharon (Everything.me) from comment #3)
> Merged in into master
> https://github.com/mozilla-b2g/gaia/commit/
> d54a6e1e78f73e7c7b030512046547933fb8dec9

John, can you assist with the uplift please?
Flags: needinfo?(jhford)
I guess this doesn't really need checkin anymore, but it does have a pretty large conflict on the v1-train branch!
Flags: needinfo?(jhford) → needinfo?(matias)
Keywords: checkin-needed
Duplicate of this bug: 828942
 (In reply to matias from comment #0)
> localStorage is blocky.
> Loading E.me freezes when there is a lot of data stored.
> 
> Need to convert to IndexedDB

how to verify this fix?  what's the definition of "blocky" and "lot of data" stored?  STR would help.
STR:
1. Reset the device and load e.me
2. The progress should fill rather quickly and load e.me
3. Perform a lot of searches- open smart folders, perform query searches
4. Restart the device
5. Load e.me again- at this point you should see a noticeable stutter at around 70% of the progress (this is because we cached data in a synchronous fashion)

With this patch applied the loading of e.me shouldn't get stuck, no matter how much data is stored.
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
QA Contact: amiller
Issue does not repro, on Leo device.
Build ID: 20130807071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/11bb1b0eefff
Gaia: 60ca81600a080dae33058b0692ecaa213556c926
Platform Version: 18.1
E.com loading as expected.
You need to log in before you can comment on or make changes to this bug.