Proxy: doesn't do localhost direct automatically

VERIFIED DUPLICATE of bug 75303

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 75303
17 years ago
17 years ago

People

(Reporter: Steve Fox, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.1+) Gecko/20010624
BuildID:    2001062405

When I am using a proxy server (either auto or manual), I cannot browse
http://localhost. If I set a noproxy for localhost (using a manual proxy server)
I can now browse http://localhost but not http://127.0.0.1. If I use an
autoproxy, I can view http://127.0.0.1 (due to the auto proxy checking for
it...see my attached PAC file) but I cannot view http://localhost. This is
different from the behavior I am used to in Netscape 4.x (although maybe this
was a design decision for those who run local proxy servers?)

Reproducible: Always
Steps to Reproduce:
See description

Actual Results:  Could not view http://localhost (both auto and manual proxy)
but can view http://127.0.0.1 using auto proxy

Expected Results:  I expected Mozilla to browse http://localhost using either an
auto proxy or a manual proxy (without having to put localhost in the noproxy
settings).
(Reporter)

Comment 1

17 years ago
Created attachment 39925 [details]
my PAC file

Comment 2

17 years ago
Dup of bug 75303, which (I'm sorry to report) is WONTFIX.

See also bug 31510, where there is some ongoing discussion of this issue.

*** This bug has been marked as a duplicate of 75303 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
I guess I didn't read bug 75303 carefully enough. I was thinking mine was
slightly different, when in fact it's not. Sorry about the extra work.

Comment 4

17 years ago
VERIFIED:
Status: RESOLVED → VERIFIED
Summary: Proxy doesn't do localhost direct automatically → Proxy: doesn't do localhost direct automatically
You need to log in before you can comment on or make changes to this bug.