Nightly doesn't open (Direct3D 10, NVIDIA GeForce GT 230M)

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: ShellHacker, Unassigned)

Tracking

24 Branch
x86
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.94 Safari/537.36

Steps to reproduce:

Clicked on the metro Nigtly tile 


Actual results:

The splash screen appeared and then crashed getting me back to the main screen.


Expected results:

Nightly should've opened
Has this ever worked for you? Or you haven't tried until now?
Never tried launching Nightly from the tile, always had an option pinned to the taskbar.
Never tried launching Nightly from the tile, always had an option pinned to the taskbar and the first time I launched, I was greeted with a beautifully designed splash screen and then crash !
Please provide the crash ID (see https://developer.mozilla.org/docs/How_to_get_a_stacktrace_for_a_bug_report#How_to_get_the_crash_ID_if_Firefox_crashes_on_startup).
Severity: normal → critical
Keywords: crash, stackwanted
OS: All → Windows 8 Metro
Hardware: All → x86
Flags: needinfo?(sudheesh1995)
Crash IDs are :
Crash ID: bp-fdb7c5bb-e311-4b25-82ab-e09252130205
Crash ID: bp-5eb59bd3-3c0a-4afc-ac99-8005a2130126
Flags: needinfo?(sudheesh1995)
Please provide recent crash IDs, those one date from Feb 5 and Jan 26.
Flags: needinfo?(sudheesh1995)
Firstly, there is no folder for nightly. In this folder

\AppData\Roaming\Mozilla\Firefox\Crash Reports

There are only 2 files in the submitted folder both of which I've mentioned above. Other files in the Pending folder which are recent are

afda69fb-7711-4e5e-9f63-47e8638ae1f8
afda69fb-7711-4e5e-9f63-47e8638ae1f8-browser
afda69fb-7711-4e5e-9f63-47e8638ae1f8-flash1
afda69fb-7711-4e5e-9f63-47e8638ae1f8-flash2
55a164f0-7342-4e30-8c21-af0874001162
7aa2cab4-f32c-45c8-a8e6-ccab1a658e0a

Update to problem: The splashscreen now appears and gets stuck for a long period of time. Its similar to having a full screen Nightly poster on screen. It just doesn't open.
Flags: needinfo?(sudheesh1995)
Try to get a stack trace if WinDbg works on Modern UI (see https://developer.mozilla.org/docs/How_to_get_a_stacktrace_with_WinDbg).
Flags: needinfo?(sudheesh1995)
Stack
Crash ID: bp-afda69fb-7711-4e5e-9f63-47e8638ae1f8

Also the Nightly app cannot be found by Windows App Certification Kit 2.2 WACK. It could mean its not installed but the desktop app is installed and both metro and desktop installation takes place at the same time
Flags: needinfo?(sudheesh1995)
(In reply to sudheesh1995 from comment #9)
> Crash ID: bp-afda69fb-7711-4e5e-9f63-47e8638ae1f8
It hasn't been submitted (no submission date at the end).
Flags: needinfo?(sudheesh1995)
The number 1360067104 is present in the file "LastCrash" in the folder \AppData\Roaming\Mozilla\Firefox\Crash Reports

Is this of any help ? what about the application not being visible on WACK 2.2 ?
Flags: needinfo?(sudheesh1995)
What is the end of submit.log?
What about WinDbg?

(In reply to sudheesh1995 from comment #11)
> what about the application not being visible on WACK 2.2 ?
MetroFirefox is not available in Windows Store because not certified.
Flags: needinfo?(sudheesh1995)
End of submit.log is
[02/05/13 17:55:16] Crash report submitted successfully

(In reply to Scoobidiver from comment #12)
> What is the end of submit.log?
> What about WinDbg?
 
But WACK also shows all store apps installed even the ones that you've created for windows store but not uploded to store. I created a random app with the name App1 and deployed it onto local machine, the app is visible on WACK, so why not Nightly ?

> > what about the application not being visible on WACK 2.2 ?
> MetroFirefox is not available in Windows Store because not certified.
Flags: needinfo?(sudheesh1995)
Keywords: crash, stackwanted
Summary: Nightly crashes on start → Nightly doesn't open
(In reply to sudheesh1995 from comment #13)
> But WACK also shows all store apps installed even the ones that you've
> created for windows store but not uploded to store. I created a random app
> with the name App1 and deployed it onto local machine, the app is visible on
> WACK, so why not Nightly ?

Firefox/Nightly is not a Windows Store App, it is a "new experience enabled Desktop Browser." Search for that term at [1]. That is likely why WACK us unaware of it.

This bug sounds very similar to bug 829127 and bug 844954. Please make sure that you are on the most recent version of Nightly. Also it might be helpful if you could post the information in the "Graphics" section of "about:support"

[1] http://msdn.microsoft.com/en-us/library/windows/apps/hh465413.aspx
Whiteboard: [triaged-on hold]
Blocks: metrov1defect&change
No longer blocks: metrov1triage
Component: Firefox Start → General
So I noticed that you are looking for crashes in AppData\Roaming\Mozilla\Firefox\Crash Reports , not AppData\Roaming\Mozilla\MetroFirefox  and that might be why we don't see the recent metro crash in your crash reports. 

Can you check that location and see if there is better data there? Also Tim suspects a graphics issue (we've had some nasty issues with certain graphics hardware), so could you please include the graphics section from about:support as he requests in comment 14?

Thanks
Flags: needinfo?(sudheesh1995)
In reply to comment 14

Adapter Description	NVIDIA GeForce GT 230M
Adapter Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM	1024
Device ID	0x0a28
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16581)
Driver Date	10-2-2012
Driver Version	9.18.13.697
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 10
Vendor ID	0x10de
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GT 230M Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo

I don't think its a graphics issue, also i can't seem to find the Roaming\Mozilla\MetroFirefox.
Flags: needinfo?(sudheesh1995)
Summary: Nightly doesn't open → Nightly doesn't open (Direct3D 10, NVIDIA GeForce GT 230M)
Blocks: metrov1planning
No longer blocks: metrov1defect&change
Still facing the same issue after following downloading the latest release at https://nightly.mozilla.org/

I had 3 tabs open before closing all and re-opening Nightly, When i clicked the updated Nightly and clicked on "Restore previous session", my session of facebook and gmail wouldn't just connect but the webpage https://nightly.mozilla.org/ would connect and show the display, but clicking on any link after that gives a "server not found" error.

Internet connection issues here after upgrade and yes, the problem of desktop app being invoked on clicking the nightly tile on windows 8 still persists.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Windows 8 only allows the default browser to launch in Metro mode.  When Nightly fails to launch in metro mode I usually do the following:
  1. Go to control panel -> default programs
  2. Select internet explorer and "set all defaults"
  3. Launch Internet Explorer in metro mode, then close it
  4. Go back to control panel -> default programs
  5. Select Nightly and "set all default"
  6. Attempt to launch Nightly from its tile

Additionally, please try using a new profile.
  0. Make sure that Nightly metro is not running
  1. Press Window key + r to open a 'run' dialog
  2. Enter "%APPDATA%" into the dialog and press enter
  3. Open the "Mozilla" directory
  4. Rename the "MetroFirefox" directory to something else (e.g. "MetroBackupProfile")
  5. Launch Nightly in metro mode
>Windows 8 only allows the default browser to launch in Metro mode.  When Nightly fails to >launch in metro mode I usually do the following:
>  1. Go to control panel -> default programs
>  2. Select internet explorer and "set all defaults"
>  3. Launch Internet Explorer in metro mode, then close it
>  4. Go back to control panel -> default programs
>  5. Select Nightly and "set all default"
>  6. Attempt to launch Nightly from its tile

Tried, Nightly still launches from Desktop mode not metro.

>Additionally, please try using a new profile.
>  0. Make sure that Nightly metro is not running
>  1. Press Window key + r to open a 'run' dialog
>  2. Enter "%APPDATA%" into the dialog and press enter
>  3. Open the "Mozilla" directory
>  4. Rename the "MetroFirefox" directory to something else (e.g. "MetroBackupProfile")
>  5. Launch Nightly in metro mode

There is no MetroFirefox folder in the APPDATA. I downloaded the most recent Nightly and still didn't get this folder. Also it doesn't connect to the internet anymore.
(In reply to Sudheesh Singanamalla (:ShellHacker) from comment #19)
> >Windows 8 only allows the default browser to launch in Metro mode.  When Nightly fails to >launch in metro mode I usually do the following:
> >  1. Go to control panel -> default programs
> >  2. Select internet explorer and "set all defaults"
> >  3. Launch Internet Explorer in metro mode, then close it
> >  4. Go back to control panel -> default programs
> >  5. Select Nightly and "set all default"
> >  6. Attempt to launch Nightly from its tile
> 
> Tried, Nightly still launches from Desktop mode not metro.

Hmm, I wonder if the shortcut on your start screen is broken/incorrect. You could try:
  1. Unpinning all Nightly shortcuts on your start screen
  2. Go to "All Apps"
  3. Find the Nightly shortcut (let us know if there are more than one of these)
  4. Select it and ping to start screen
  5. Go through the steps above (make IE default, run IE, then switch back)

> >Additionally, please try using a new profile.
> >  0. Make sure that Nightly metro is not running
> >  1. Press Window key + r to open a 'run' dialog
> >  2. Enter "%APPDATA%" into the dialog and press enter
> >  3. Open the "Mozilla" directory
> >  4. Rename the "MetroFirefox" directory to something else (e.g. "MetroBackupProfile")
> >  5. Launch Nightly in metro mode
> 
> There is no MetroFirefox folder in the APPDATA. I downloaded the most recent
> Nightly and still didn't get this folder. Also it doesn't connect to the
> internet anymore.

The folder "%APPDATA%\Mozilla\MetroFirefox" should be created the first time that Metro Nightly launches. Since Metro Nightly doesn't seem to launch on your machine, that's probably why the folder doesn't exist yet. Hopefully we'll get there :)

When you say that "it doesn't connect to the internet," are you talking about Desktop Nightly? I'm asking because it sounds like Metro Nightly isn't launching at all on your machine.
>Hmm, I wonder if the shortcut on your start screen is broken/incorrect. You could try:
>  1. Unpinning all Nightly shortcuts on your start screen
>  2. Go to "All Apps"
>  3. Find the Nightly shortcut (let us know if there are more than one of these)
>  4. Select it and ping to start screen
>  5. Go through the steps above (make IE default, run IE, then switch back)

Ye, the shortcut is incorrect. I unpinned the nightly but it unpinned it from both my taskbar on desktop and from start. There is only one nightly icon/executable when the search opens. Running it still opens dekstop mode with start screen.

>When you say that "it doesn't connect to the internet," are you talking about Desktop >Nightly? I'm asking because it sounds like Metro Nightly isn't launching at all on your >machine.

Yes the desktop nightly, I guess this is similar to a few people experiencing no network connections after update to new firefox, this was all over the Army of Awesome initially when Firefox 22 was released.
(In reply to Sudheesh Singanamalla (:ShellHacker) from comment #21)

> Yes the desktop nightly, I guess this is similar to a few people
> experiencing no network connections after update to new firefox, this was
> all over the Army of Awesome initially when Firefox 22 was released.

This is usually a firewall not yet updated to recognize the new Firefox exe or similar.
Blocks: metrov2planning
No longer blocks: metrov1planning
No longer blocks: metrov2planning
Whiteboard: [triaged-on hold]
Whiteboard: [defect]
Whiteboard: [defect] → [defect] p=0
No longer blocks: metrobacklog
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [defect] p=0
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.