All users were logged out of Bugzilla on October 13th, 2018

[build failed] win64 build broken after m-c 448e9861db9f

RESOLVED DUPLICATE of bug 876691

Status

RESOLVED DUPLICATE of bug 876691
6 years ago
8 months ago

People

(Reporter: hATrayflood, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

6 years ago
nsMemoryInfoDumper.cpp
s:\mozilla\central\mozilla-central\config\rules.mk:1141:0$ s:/mozilla/central/firefox-win64-sdk71-132998_77a7b3045825/_virtualenv/Scripts/python.exe -O s:/mozilla/central/mozilla-central/build/cl.py cl -FonsMemoryInfoDumper.obj -c -D_HAS_EXCEPTIONS=0 -I../../dist/stl_wrappers  -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DNO_NSPR_10_SUPPORT -DEXCLUDE_SKIA_DEPENDENCIES  -DUNICODE -D_UNICODE -DNOMINMAX -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -D_SECURE_ATL -DCHROMIUM_BUILD -DU_STATIC_IMPLEMENTATION -DOS_WIN=1 -DWIN32 -D_WIN32 -D_WINDOWS -DWIN32_LEAN_AND_MEAN  -DCOMPILER_MSVC -D_IMPL_NS_COM -Is:/mozilla/central/mozilla-central/ipc/chromium/src -Is:/mozilla/central/mozilla-central/ipc/glue -I../../ipc/ipdl/_ipdlheaders  -Is:/mozilla/central/mozilla-central/xpcom/base/../build -Is:/mozilla/central/mozilla-central/xpcom/ds  -Is:/mozilla/central/mozilla-central/xpcom/base -I. -I../../dist/include  -Is:/mozilla/central/firefox-win64-sdk71-132998_77a7b3045825/dist/include/nspr -Is:/mozilla/central/firefox-win64-sdk71-132998_77a7b3045825/dist/include/nss        -wd4099 -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4251 -wd4244 -wd4345 -wd4351 -wd4482 -wd4800 -wd4819 -we4553 -GR-  -DNDEBUG -DTRIMMED -O1 -Oy -MD            -FI ../../dist/include/mozilla-config.h -DMOZILLA_CLIENT  s:/mozilla/central/mozilla-central/xpcom/base/nsMemoryInfoDumper.cpp
nsMemoryInfoDumper.cpp

s:\mozilla\central\firefox-win64-sdk71-132998_77a7b3045825\dist\include\nsTSubstring.h(358) : warning C4267: 'argument' : conversion from 'size_t' to 'nsAString_internal::size_type', possible loss of data

s:\mozilla\central\firefox-win64-sdk71-132998_77a7b3045825\dist\include\nsTSubstring.h(362) : warning C4267: 'argument' : conversion from 'size_t' to 'nsAString_internal::size_type', possible loss of data

s:\mozilla\central\firefox-win64-sdk71-132998_77a7b3045825\dist\include\nsTSubstring.h(358) : warning C4267: 'argument' : conversion from 'size_t' to 'nsACString_internal::size_type', possible loss of data

s:\mozilla\central\firefox-win64-sdk71-132998_77a7b3045825\dist\include\nsTSubstring.h(362) : warning C4267: 'argument' : conversion from 'size_t' to 'nsACString_internal::size_type', possible loss of data

../../dist/include\mozilla/Atomics.h(623) : error C2061: syntax error : identifier 'T'

../../dist/include\mozilla/Atomics.h(624) : error C2065: 'ptr' : undeclared identifier

../../dist/include\mozilla/Atomics.h(624) : error C2065: 'newVal' : undeclared identifier

../../dist/include\mozilla/Atomics.h(624) : error C2065: 'oldVal' : undeclared identifier

../../dist/include\mozilla/Atomics.h(624) : error C2065: 'oldVal' : undeclared identifier

c1xx : fatal error C1903: unable to recover from previous error(s); stopping compilation

s:\mozilla\central\mozilla-central\config\rules.mk:1141:0: command 's:/mozilla/central/firefox-win64-sdk71-132998_77a7b3045825/_virtualenv/Scripts/python.exe -O s:/mozilla/central/mozilla-central/build/cl.py cl -FonsMemoryInfoDumper.obj -c -D_HAS_EXCEPTIONS=0 -I../../dist/stl_wrappers  -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DNO_NSPR_10_SUPPORT -DEXCLUDE_SKIA_DEPENDENCIES  -DUNICODE -D_UNICODE -DNOMINMAX -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -D_SECURE_ATL -DCHROMIUM_BUILD -DU_STATIC_IMPLEMENTATION -DOS_WIN=1 -DWIN32 -D_WIN32 -D_WINDOWS -DWIN32_LEAN_AND_MEAN  -DCOMPILER_MSVC -D_IMPL_NS_COM -Is:/mozilla/central/mozilla-central/ipc/chromium/src -Is:/mozilla/central/mozilla-central/ipc/glue -I../../ipc/ipdl/_ipdlheaders  -Is:/mozilla/central/mozilla-central/xpcom/base/../build -Is:/mozilla/central/mozilla-central/xpcom/ds  -Is:/mozilla/central/mozilla-central/xpcom/base -I. -I../../dist/include  -Is:/mozilla/central/firefox-win64-sdk71-132998_77a7b3045825/dist/include/nspr -Is:/mozilla/central/firefox-win64-sdk71-132998_77a7b3045825/dist/include/nss        -wd4099 -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4251 -wd4244 -wd4345 -wd4351 -wd4482 -wd4800 -wd4819 -we4553 -GR-  -DNDEBUG -DTRIMMED -O1 -Oy -MD            -FI ../../dist/include/mozilla-config.h -DMOZILLA_CLIENT  s:/mozilla/central/mozilla-central/xpcom/base/nsMemoryInfoDumper.cpp' failed, return code 2
s:\mozilla\central\mozilla-central\config\makefiles\target_libs.mk:59:0: command 's:/mozilla-build/python/python.exe s:/pymake/pymake/../make.py -C base libs' failed, return code 2
s:\mozilla\central\mozilla-central\config\makefiles\target_libs.mk:17:0: command 's:/mozilla-build/python/python.exe s:/pymake/pymake/../make.py -C xpcom libs' failed, return code 2
evaluation from s:\mozilla\central\mozilla-central\config\rules.mk:738:24:23:0: command 's:/mozilla-build/python/python.exe s:/pymake/pymake/../make.py libs_tier_platform' failed, return code 2
s:\mozilla\central\mozilla-central\config\rules.mk:672:0: command 's:/mozilla-build/python/python.exe s:/pymake/pymake/../make.py  tier_platform' failed, return code 2
s:\mozilla\central\mozilla-central\client.mk:372:0: command 's:/mozilla-build/python/python.exe s:/pymake/pymake/../make.py -j1 -C ../firefox-win64-sdk71-132998_77a7b3045825' failed, return code 2
s:\mozilla\central\mozilla-central\client.mk:172:0: command 's:/mozilla-build/python/python.exe s:/pymake/pymake/../make.py -f s:/mozilla/central/mozilla-central/client.mk realbuild' failed, return code 2
(Reporter)

Comment 1

6 years ago
it seems from http://hg.mozilla.org/mozilla-central/rev/448e9861db9f
maybe, template type "T" is not supported on vc10.
(Reporter)

Comment 2

6 years ago
Created attachment 754242 [details] [diff] [review]
fix v1
Attachment #754242 - Flags: review?(nfroyd)
Duplicate of this bug: 876329
(Reporter)

Updated

6 years ago
Hardware: x86 → x86_64
(Reporter)

Updated

6 years ago
Summary: [build failed] build broken after 448e9861db9f → [build failed] win64 build broken after m-c 448e9861db9f
I forgot to tell jlebar this bug existed, so he filed-and-fixed it in bug 876691.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 876691
Attachment #754242 - Attachment is obsolete: true
Attachment #754242 - Flags: review?(nfroyd)

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.