If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

weather.com weather map says its incompatible despite loading correctly

RESOLVED FIXED

Status

Tech Evangelism
Mobile
P3
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Leman Bennett [Omega], Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serversniff][m3u][video][contactready] [country-all], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20130526 Firefox/24.0 (Nightly/Aurora)
Build ID: 20130526031046

Steps to reproduce:

Checking weather maps on Weather.com despite loading completely will tell you that its not compatible with your browser and tries to redirect.

STR:

- Go to weather.com and enter your zipcode in the search box.
- Scroll to the bottom and "Enlarge Map".

Desktop Firefox has no trouble loading this map, but Android Firefox will throw the incompatible error overlay. If you wait long enough, that map will correctly load underneath the overlay.
(Reporter)

Comment 1

4 years ago
Forgot to mention that this was on Android 4.3 and Nexus 7 in Desktop Mode.
OS: Windows 8 → Android
Hardware: x86_64 → ARM
This means that the authors of Weather.com are specifically targeting iOS devices which is the wrong way to do things.

Feel free to contact Weather.com to inform them that there is more to the web than the iPhone.
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 21 → unspecified
Weather apparently serves a lo-fi mobile site (mw.weather.com) to the Firefox Android user agent. The hi-fi mobile site (m.weather.com) seems to work fine when spoofing (Desktop), but I'm not sure about the site's video content. Could somebody get back to this and check if the video content is in a format that works on either Fx on Android or FxOS?
Whiteboard: [serversniff]
(Assignee)

Updated

4 years ago
Whiteboard: [serversniff] → [contactready]
(Assignee)

Updated

4 years ago
Whiteboard: [contactready] → [contactready] [serversniff]
The site serves all video content as M3U playlists when spoofing as iOS Safari, but serves MP4 and works fine if spoofing as Android stock browser.
Whiteboard: [contactready] [serversniff] → [serversniff][m3u][video][contactready]
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

4 years ago
The map now works when you force "Desktop Version" in Mobile Firefox. This issue seems to be fixed now. For some reason it now defaults to mw.weather.com if that setting is not enabled. Mobile Chrome is sent to the desktop version on a tablet.

Also, I noticed that Mobile Chrome on a smartphone defaults to http://m.weather.com/.

m.weather.com will default to mw.weather.com if using Mobile Firefox on any device, tablet or phone.

I guess that I should mark this fixed an open up a new bug?
It's great that things have improved. If there are functional or aestetic differences that makes the m.weather.com version noticeably better than the m.weather.com one, we should probably keep reaching out to get the m.weather.com one. I'm happy to use this bug for that. As you're probably more familiar with the site than I am: how do you think the two sites compare?
(Reporter)

Comment 7

4 years ago
m.weather.com is MUCH more easier on the eyes than mw.weather.com. mw.weather.com is practically one of those old WAP browser pages where only basic text and layout were the only way to do mobile web back in the gap.
(Reporter)

Comment 8

4 years ago
Created attachment 806434 [details]
http://m.weather.com

New mobile site.
(Reporter)

Comment 9

4 years ago
Created attachment 806435 [details]
http://mw.weather.com

Old mobile site that Mobile Firefox gets redirected to.
In that case we'll definitely keep this bug open and try to reach out to weather.com to get the nicer version. If you wish to help with the outreach feel free to contact the site (or just gather contact information and tell us - comment in the bug if it's public like a link to a "contact us" form, send me an E-mail if it's more private like the E-mail or Twitter nick of a weather.com employee)
Priority: -- → P3
Duplicate of this bug: 653181
(Assignee)

Comment 12

4 years ago
fwiw, in my past at Opera, trying to contact weather.com has been a time sink. I will try again.
Whiteboard: [serversniff][m3u][video][contactready] → [serversniff][m3u][video][contactready] [country-all]
(Assignee)

Updated

4 years ago
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
(Assignee)

Comment 13

4 years ago
So wait… I just checked on Firefox for Android.

1. Enter http://www.weather.com/
2. Get redirected to http://m.weather.com/
3. Ask for location (example enter Toronto)
4. Get the page for Toronto

The bottom has no enlarge, the full design is quite neat. and no issue visible.

5. Click on hourly. No issue
6. Go on the map and click on it. No issue.

I will close as FIXED. 
I will open a separate bug for Firefox OS, which receives the desktop site.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.