Closed Bug 876327 Opened 9 years ago Closed 9 years ago

libcubeb needs a Solaris backend

Categories

(Core :: Audio/Video, defect)

22 Branch
x86
Solaris
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: choope1, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; SunOS i86pc; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130524143229

Steps to reproduce:

The Firefox 22.0b1 and b2 OpenSolaris i386 builds do not play audio on YouTube html5 videos. Flash is disabled. Many YouTube videos will play in html5 if Flash is disabled. I tried enabling Flash and viewing the same video. The Flash plugin crashes repeatedly, so don't know if sound plays with Flash.

I checked with 21.0b7 and sound does play.


Actual results:

The video plays but there is no audio.


Expected results:

The audio should be heard.
Do you have sound with this video e.g.?
http://clips.vorwaerts-gmbh.de/big_buck_bunny.webm

If it's possible on Solaris, could you run the tool mozregression to find a regression range (see http://harthur.github.io/mozregression/ for details).

Firefox 22 nightlies started in Feb 2013 (--good=2013-02-01).
Component: Untriaged → Video/Audio
Flags: needinfo?(choope1)
Product: Firefox → Core
The old sound library (libsydneyaudio) was removed in Firefox 22.  Nobody has contributed a Solaris backend for the new sound library (libcubeb) yet.
Blocks: 852401
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(choope1)
Summary: Firefox 22.0 beta Solaris build has no audio with YouTube html5 videos → libcubeb needs a Solaris backend
There is no sound with the clip you linked to with the Firefox 22 branch and there is with 21. The removal of a sound library would explain why this is happening.

The Firefox, Thunderbird and Lightning builds are contributed by the Oracle Solaris Desktop Beijing Team. Ginn Chen has responded to other Firefox bugs. I would suggest to contact him.
FWIW:
On Solaris 11 or above, compile Firefox with --enable-pulseaudio will have sound.
I'm using OpenIndiana. PulseAudio is not in the repos. According to Alan Coopersmith's blog, library/audio/pulseaudio 1.1 was added to Solaris 11.1.

about:buildconfig does not show --enable-pulseaudio

Configure arguments

--enable-application=browser --prefix=/usr --libdir=/usr/lib --mandir=/usr/share/man --enable-official-branding --enable-updater --enable-debug-symbols=no --enable-update-packaging --enable-update-channel=beta --disable-tests --enable-jemalloc --enable-dtrace --enable-xinerama --disable-crashreporter --enable-ipc
This bug can be marked solved and closed. I've used 23.0b5, 23.0.1, 24.0b9 and 24.0b10. All have sound with html5 videos. Thank you.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Depends on: 952828
You need to log in before you can comment on or make changes to this bug.