Closed Bug 876391 Opened 10 years ago Closed 10 years ago

T-Mobile_Poland operator shelf not showing up in the listed categories on the homepage

Categories

(Marketplace Graveyard :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2013-07-04

People

(Reporter: eder.mozbugs, Assigned: cvan)

References

Details

(Whiteboard: [qa+] p=1)

Attachments

(6 files)

steps to reproduce:

1. Open Marketplace via data or WiFi connection
2. in the operator shelf not showing up in the listed categories on the homepage

expected behavior:

in the operator shelf must showing up in the listed categories on the homepage


observed behavior:


the operator "T-Mobile" not showing up in the listed categories on the homepage
Component: Payments/Refunds → General
OS: Gonk (Firefox OS) → Windows 7
Hardware: Other → x86
Version: 1.1 → 1.0
The test operator shelf is named "Krupa's T-mobile op Shelf". Also, did you test this on -dev?
yes, I am performing the tests in Market Place_Dev, and I can't see the name Krupa's T-mobile
Krupa - can you reproduce this?
Flags: needinfo?(krupa.mozbugs)
This seems similar to bug 876386 - Krupa, can you confirm?
This will be fixed by 877490.
Flags: needinfo?(krupa.mozbugs)
Can you try this again?
Flags: needinfo?(krupa.mozbugs)
How do we even have a T-Mobile operator shelf when T-Mobile isn't even a carrier in our constants?

https://github.com/mozilla/zamboni/blob/master/mkt/constants/carriers.py
(In reply to Matt Basta [:basta] from comment #7)
> How do we even have a T-Mobile operator shelf when T-Mobile isn't even a
> carrier in our constants?
> 
> https://github.com/mozilla/zamboni/blob/master/mkt/constants/carriers.py

DT owns t-mobile
I can see the dt-pl "Polecamy" shelf on prod when I set my carrier to DT and my region to PO. I can't try on -dev because of bug 884262.

Good to close?
I made it easier to know which region you're in with bug 877490. This looks fixed to me.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I made it easier to know which region you're in with bug 877490. This looks fixed to me.
Status: NEW → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Assignee: nobody → cvan
Target Milestone: --- → 2013-06-06
Whiteboard: p=1
operator "T-Mobile" is still not showing up in the listed categories on the homepage
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Vikas Nanda from comment #12)
> operator "T-Mobile" is still not showing up in the listed categories on the
> homepage

Can you please provide screenshots and logs when reopening bugs? It'll help to diagnose this bug.
Attached image categories
Attached image categories_2
Christopher, I have included a couple of screenshots to show that T-mobile isn't listed under categories. 

Let me know if you need any further info

Thanks
Vikas can you please press and hold on the logo in the upper left to open the debug panel, then press Submit logs and copy the id that it gives you into the bug
Matt, 

The ID is 446b1

Thanks
Vikas: it looks like your carrier is not set and you don't have a SIM (or your SIM isn't accessible). That means you won't see the operator shelf for T-Mobile in Poland.

Please use a SIM from DT/T-Mobile and try again.
Flags: needinfo?(krupa.mozbugs) → needinfo?(eder.mozbugs)
Matt: I have tried 2 t-mobile-pl sim cards and with both I get the same issue. Under options the carrier is set to T-mobile PL.
cvan: looks like the MCC/MNC aren't being fetched form the SIM

[mobilenetwork] Error accessing navigator.mozMobileConnection
Flags: needinfo?(eder.mozbugs)
Vikas: What version of B2G are you testing with?
Matt: I am testing with version Boot2Gecko 1.0.1.0-prerelease (6-24-13)
I landed this on Friday:

https://github.com/mozilla/fireplace/commit/f2aec5714abab731433d3362908740cfc09a595d

We had a bug in the way we were choosing the carrier when you've previously installed a SIM but put in a new one. That might help.

Otherwise, the log data that you've provided is showing that there's no network data available (no carrier/region). That sounds like a platform bug and there's not a lot we can do about it.

Cvan: What do you think?
Flags: needinfo?(cvan)
Flags: needinfo?(cvan)
Target Milestone: 2013-06-06 → 2013-06-27
https://marketplace-dev.allizom.org/api/v1/apps/search/featured/?_user=---&cat=&dev=firefoxos&device=firefoxos&lang=en-US&mcc=260&mnc=022072669878

The MNC for your Polish SIM is getting reported as 022072669878. That's bug 880369. Try flashing your phone to a daily development build, and let me know what it comes back as.
Assignee: cvan → nobody
On -dev, I get 

MCC: "260"
MNC: "021373417656"
Yep, same bug :\ Thanks :)
Target Milestone: 2013-06-27 → 2013-07-04
Resolving since bug 880369 is fixed. Please flash with the appropriate build and try again.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
(In reply to Matt Basta [:basta] from comment #28)
> Resolving since bug 880369 is fixed. Please flash with the appropriate build
> and try again.

Matt, I have tried this again on MP Stage FW 1.0.1 (updated 06/28/13) and I am still getting the same issue.
It looks like bug 880369 is for 1.1. Can you try with a 1.1 build?
https://github.com/mozilla/fireplace/commit/979afe6

Hacks on hacks on hacks!
Assignee: nobody → cvan
Whiteboard: p=1 → [qa+] p=1
error still reproducible on 1.01
Attached image categories1
Attached image categories2
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Can you please submit your logs for this issue?

https://github.com/mozilla/fireplace/blob/master/ashes/README.md#submitting-logs
Flags: needinfo?(sailajan.sabaratnam)
log attached
(In reply to sailajan.sabaratnam from comment #39)
> log attached

Please follow the instructions at the link in comment #37. logcat/ezboot logs are not useful to us.
Flags: needinfo?(sailajan.sabaratnam)
ID: f7888
Flags: needinfo?(sailajan.sabaratnam)
Please ignore the previous ID in comment 41. The ID for the bug is ID: f7dfd
sailajan: It looks like, from your logs, that you don't have a carrier set. This is caused by not having a SIM card installed, the marketplace was installed onto the device in a way that is not recommended (or accessed through the browser), or the device is not recognizing the SIM card appropriately:

> [mobilenetwork] navigator.mozMobileConnection unavailable

This means that the Marketplace attempted to access your SIM but it was not allowed to, for one of the reasons listed above.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Please use the packaged app version of the Marketplace that ships with Gaia or if you're testing on -dev or stage:

https://marketplace-dev.allizom.org/app/marketplace/
https://marketplace.allizom.org/app/marketplace/
(In reply to Christopher Van Wiemeersch [:cvan] from comment #44)
> Please use the packaged app version of the Marketplace that ships with Gaia
> or if you're testing on -dev or stage:
> 
> https://marketplace-dev.allizom.org/app/marketplace/
> https://marketplace.allizom.org/app/marketplace/

QA is blocked from using stage packaged app until we have certs. This is being tracked at bug 877531
(In reply to krupa raj[:krupa] from comment #45)
> (In reply to Christopher Van Wiemeersch [:cvan] from comment #44)
> > Please use the packaged app version of the Marketplace that ships with Gaia
> > or if you're testing on -dev or stage:
> > 
> > https://marketplace-dev.allizom.org/app/marketplace/
> > https://marketplace.allizom.org/app/marketplace/
> 
> QA is blocked from using stage packaged app until we have certs. This is
> being tracked at bug 877531

:( Carrier detection won't work within any hosted version of the Marketplace though (as the SIM API is a privileged API), so we'll need to test against -dev and prod for the time being :\
You need to log in before you can comment on or make changes to this bug.