If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox stuck after looking up host

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Andy, Unassigned)

Tracking

21 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512193848

Steps to reproduce:

After upgrading to Ubuntu 13.04 Firefox has this strange behaviour that it stops working after a while.


Actual results:

When trying to reload ANY page I'll get the message "looked up host" in the status bar, but then Firefox is stuck with the loading animation, which never ends.


Expected results:

The message "looked up host" should disappear, being replaced by "waiting for host" or something, and a loading page.
(Reporter)

Comment 1

4 years ago
Restarting Firefox all together solves the problem for a while.
(Reporter)

Comment 2

4 years ago
The problem got fixed in one of the recent updates.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 3

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0

I recently upgraded to Ubuntu 13.04, and Firefox exhibits the same symptoms as mentioned before.

Chrome/Chromium do not have similar issues (just to make sure that its not a
networking issue)

And yes restarting Firefox solves the issue for a while. I am on the latest Firefox from Ubuntu:  22.0+build2-0ubuntu0.13 amd64

Comment 4

4 years ago
Using Firefox 23.0 on gentoo, and this happens on the profile with 30-40 tabs, about every hour or so, hangs with the "Looked up XXXX.site.com" in the status bar at the bottom. Can let it resolve, sometimes takes as long as 15 minutes, but restarting firefox solves the issue. Recently upgraded to 23.0 on amd64, this has been happening since 13.0 through 17.0.8. Have a minimal set of extensions, adblock and noscript being two of the larger ones. Will run firefox with strace from now on to see if I can see what it's hanging on.
I am also seeing this on Gentoo. Strange thing is, everything has been working smoothly for months. Only recent change for me is going from kernel 3.10.8 to 3.10.11.
Just discovered that doing "Work Offline" toggle on/off restores sanity and everything is smooth again. I wonder for how long.

Comment 7

4 years ago
Yes, for months, suffered from this bug. on my Ubuntu 12.04, if I run it for days.

toggling on/off "work offline" seems work for hours

once, I disable and enable the networking of Ubuntu, but firefox hangs "looked up ..." within minutes.

Comment 8

4 years ago
I keep seeing this on my archlinux (Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0), it happens every several hours, mostly after the browser has been idle, with several tabs open, for some time. Very annoying. Toggling "offline" helps [for several more hours], thanks to Leho Kraav.

Comment 9

4 years ago
Same thing here. Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

I believe this bug have to be reopened. There are plenty of reporters, and if any debug info needed, one can just ask.

Comment 10

3 years ago
See it here with FF 29.0.1 on Linux 3.14.5.
Stop/start of FF fixes the issue, but that is no solution....

Comment 11

3 years ago
It happens daily, at least. Please fix.
I have not seen this for months now. Could be related to some local system configuration thing that is general enough to trigger this.

Comment 13

3 years ago
Sure, but why does it pop up after installing FF 29?
Why didn't I change that much recently?
Even worse, I was away from keyboard in the most extreme way possible for mere humans: I was at the other side of the planet for about five weeks.
So I cannot think of any way the problem was because of a recent change except for updating to FF 29.
So please help find the cause.
It isn't directly related only to FF 29. I ran into this much earlier.

Comment 15

3 years ago
So why then didn't I and did I only now?
It is a weird problem that we need to find the root cause of.
Especially this FF29 fixes the main (flash) issue for a big part.

Comment 16

3 years ago
I have the same problem with FF29 under Linux 64-bit. I did not have the same problem with FF28. It takes about 2 hours of usage to reproduce the problem.

Comment 17

3 years ago
Created attachment 8438041 [details]
strace snippet

This is a snippet of strace output for FF29 running on Ubuntu 14.04 64bits while stuck with this bug.
You need to log in before you can comment on or make changes to this bug.