Last Comment Bug 876497 - Add 'Show an alert' checkbox to OSX Preferences
: Add 'Show an alert' checkbox to OSX Preferences
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: All Mac OS X
: -- normal with 1 vote (vote)
: Thunderbird 24.0
Assigned To: Richard Marti (:Paenglab)
:
Mentors:
https://groups.google.com/forum/?from...
: 879559 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 12:09 PDT by Richard Marti (:Paenglab)
Modified: 2013-06-25 05:20 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed


Attachments
patch (1.43 KB, patch)
2013-05-27 12:11 PDT, Richard Marti (:Paenglab)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Review
screenshot for easier ui-r (53.78 KB, image/png)
2013-05-27 12:13 PDT, Richard Marti (:Paenglab)
no flags Details

Description Richard Marti (:Paenglab) 2013-05-27 12:09:15 PDT
With OS X using now the built-in notifications the user should be able to deactivate them easily like on Linux and Windows in Preferences window.
Comment 1 Richard Marti (:Paenglab) 2013-05-27 12:11:48 PDT
Created attachment 754548 [details] [diff] [review]
patch

This patch adds only the already existing lines for Linux/Windows to the OS X #ifdef part.
Comment 2 Richard Marti (:Paenglab) 2013-05-27 12:13:10 PDT
Created attachment 754549 [details]
screenshot for easier ui-r
Comment 3 rsx11m 2013-06-05 06:17:45 PDT
Is bug 879559 a duplicate of this one? Looks like that. I don't have a Mac, thus cannot comment on the interaction with Growl, but have a look at the test for the notification service I mention in bug 879559 comment #2 if it's the right thing.
Comment 4 Richard Marti (:Paenglab) 2013-06-05 06:38:23 PDT
*** Bug 879559 has been marked as a duplicate of this bug. ***
Comment 5 Blake Winton (:bwinton) (:☕️) 2013-06-16 13:40:34 PDT
Comment on attachment 754548 [details] [diff] [review]
patch

ui-r=me, although I'm starting to worry about the number of things we're adding here, what with the dock options, and all…

And the code is simple enough, so r=me, too.
Comment 6 Ryan VanderMeulen [:RyanVM] 2013-06-18 08:40:18 PDT
https://hg.mozilla.org/comm-central/rev/824f5c8fdae2

Note You need to log in before you can comment on or make changes to this bug.