Closed Bug 876543 Opened 7 years ago Closed 7 years ago

[Settings] Configure voicemail info through the Settings App

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P1, major)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- verified
b2g-v1.1hd --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: jaoo)

References

Details

Attachments

(4 files)

1. Title :  When calling voicemail, call screen doesn't notify that this call is voicemail.
2. Precondition : 
3. Tester's Action : Call voicemail
4. Detailed Symptom : only show number
5. Expected : show string "voicemail"
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train : Reproduce
8. Gaia Revision : a503d9a1d0a588f3689243c1ddc0f016ede51b9d
9. Gecko Revision : a79f866b03fe1dd5107a83974fac43c2036a8bc8
10 Personal email id : promise09th@gmail.com
I added tester's action

3. Tester's Action : Call voicemial or long press number '1' in dialer
If the VM info is stored in the ICC card the dialer gets the VM number and the label to be shown in the dial when dialing from the mozVoiceMail API. In case that info is not stored the dialer tries to find the VM in the value stored in the settings database under the 'ril.iccInfo.mbdn' key but we don't have a label to be shown. I propose to add a default one e.g. 'Voicemail' (and localize that label of couse) and use it in case the VM number is actually stored in the settings app. Etienne, Germán, does it sound good to you guys? With this support we will fix bug 864555.

On the other hand the dialer might not be able to dial the VM service in case the VM number is even not stored in the setting database. What about alerting the user and let him/her configure the VM info in the Settings App in the 'Call Settings' panel? Requesting ni? to the UX team.
Assignee: nobody → josea.olivera
Flags: needinfo?(gtorodelvalle)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(etienne)
Assigning to Francis since he is on Dialer. Leo+, tef+ and tracking bugs are UX's  top priorities right now, so if this does not make leo nom it won't carry the same priority.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(fdjabri)
Hi guys! Apart from the fact that right now we are not considering the second option pointed out by José Antonio when showing the "Voicemail" message (this will be solved in bug 864555) (you may have a look at https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/handled_call.js#L118 for further details), I guess we should focus in this bug in the case when neither the mozVoicemail nor the Settings's ril.iccInfo.mbdn provides the Voicemail number. In this case, I think José Antonio's proposal is perfectly fine, I mean letting the user configure it in the Settings app as for example Android does.
Flags: needinfo?(gtorodelvalle)
Changing but tittle per comment #22 in bug 864555. (https://bugzilla.mozilla.org/show_bug.cgi?id=864555#c22)
Component: Gaia::Dialer → Gaia::Settings
Summary: [Dialer] When calling voicemail, call screen doesn't notify that this call is voicemail. → [Settings] Let the user to configure voicemail info through the Settings App
Summary: [Settings] Let the user to configure voicemail info through the Settings App → [Settings] Configure voicemail info through the Settings App
WIP

Kaze, this patch adds the bits to be able to configure the voice mail number through the Setting App. It just adds a sub panel within the 'Call Settings' sub panel. We are still waiting the UX input here but I guess we would need to do something like this. Could you take a look please? Thanks.
Attachment #755349 - Flags: feedback?(kaze)
David, as you are aware of certification stuff, just a doubt about how the voice mail number is supposed to be used. The user might change the voice mail number through the Setting App and from that moment use the new number. So the thing is that we wouldn't use the one stored in the SIM card. I guess this is not a problem for the certification tests since other OSes allow to change the VM number, is it? Thanks!
Flags: needinfo?(dpv)
Comment on attachment 755349 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/10076

The rationale looks OK to me.

As you wrote, some UX wireframes are required — the main “Data Call” panel looks a bit weird like that.
Attachment #755349 - Flags: feedback?(kaze) → feedback+
blocking-b2g: leo? → leo+
Flags: needinfo?(fdjabri)
Flags: needinfo?(kyee)
Flags: needinfo?(kyee) → needinfo?(jcarpenter)
I'll be handling this bug on behalf of Francis, who is trés slammed.

(In reply to Fabien Cazenave [:kaze] from comment #8)
 
> As you wrote, some UX wireframes are required — the main “Data Call” panel
> looks a bit weird like that.

Can you attach a screenshot?
Flags: needinfo?(jcarpenter)
Attached image Screenshot
Screenshot attached.
Flags: needinfo?(jcarpenter)
Assigning to Francis.
Flags: needinfo?(jcarpenter)
Flags: needinfo?(fdjabri)
Attached image Voicemail flow
Hi, 

The wireframes look good to me but I have a couple of suggested changes:

1) push forward the VM number so that it is shown in the Voicemail list item at the "Call Settings" level. If a number has not yet been defined, show the string: "Not set".

2) Use a voicemail icon for the voicemail list items at the "Call Settings" and the "Voicemail" levels.

PS. Please also use the term "Voicemail" and not "Voice Mail" for consistency with other strings in the UI.
Flags: needinfo?(fdjabri)
Thanks Francis, If the VM number is not stored in the SIM the dialer couldn't go to the VM service by long pressing the #1 key in the dialer app, what about showing an alert in the dialer when that happens? After that the user would know she/he needs to setup the VM number in the Setting App.
Clearing the needinfo until we're clear on the UX.
Flags: needinfo?(etienne)
Comment on attachment 755349 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/10076

Kaze, Etienne, the comments from UX have been addressed and it's time to do the review. There are changes in both the dialer and the setting app, could you guys take a look please? Thanks!
Attachment #755349 - Flags: review?(kaze)
Attachment #755349 - Flags: review?(etienne)
Flags: needinfo?(dpv)
The code is OK for me, but I’m troubled by the UX (attachment 756870 [details]):
 • the point that initially worried me (= the “Voicemail” is not separated from the rest of the call settings) is still there;
 • the “Voicemail” icon is not consistent with other Settings icons (much higher contrast); besides, no other setting item has its own icon like that (except on the root panel).

Waiting for Larissa’s feedback before r+’ing.
Flags: needinfo?(lco)
(In reply to Fabien Cazenave [:kaze] from comment #16)
> The code is OK for me, but I’m troubled by the UX (attachment 756870 [details]
> [details]):
>  • the point that initially worried me (= the “Voicemail” is not separated
> from the rest of the call settings) is still there;

It seems strange to break out Voicemail into a new sub-category if it only contains one setting. Therefore, I agree with Jose's approach. 

>  • the “Voicemail” icon is not consistent with other Settings icons (much
> higher contrast); besides, no other setting item has its own icon like that
> (except on the root panel).

I agree with you on this. The icon wasn't meant to be the final graphic in any case, but I agree including it at this level breaks up the uniformity somewhat, so on balance it's better to remove. 

> 
> Waiting for Larissa’s feedback before r+’ing.

I am the UX owner for the Dialer, so removing Larissa's need info, but Larissa, you're welcome to comment of course.
Flags: needinfo?(lco)
Attached image call settings
Updated screenshot without the VM icon
(In reply to Francis Djabri [:djabber] from comment #17)

> > Waiting for Larissa’s feedback before r+’ing.
> 
> I am the UX owner for the Dialer, so removing Larissa's need info, but
> Larissa, you're welcome to comment of course.

No, glad you're taking this :) The screenshot you uploaded looks fine to me!
Thanks for the quick feedback Francis!

(In reply to Francis Djabri [:djabber] from comment #17)
> (In reply to Fabien Cazenave [:kaze] from comment #16)
> > The code is OK for me, but I’m troubled by the UX (attachment 756870 [details]
> > [details]):
> >  • the point that initially worried me (= the “Voicemail” is not separated
> > from the rest of the call settings) is still there;
> 
> It seems strange to break out Voicemail into a new sub-category if it only
> contains one setting. Therefore, I agree with Jose's approach.

FTR, there are other examples like that in the Settings app, e.g. at the bottom of the Device information > More Information panel (= git commit / developer items); but I agree a new sub-category is not necessarily the best option…

My point was, it is not obvious for me that clicking on this new “Voicemail” item should call another panel.

For such cases we often rely on buttons (see the “More information” button in the “Device information” panel) — and if we used a button here, we /could/ use a simple `window.prompt()' call, like for the Bluetooth > “Rename my device” case. 

(In reply to Francis Djabri [:djabber] from comment #17)
> > Waiting for Larissa’s feedback before r+’ing.
> 
> I am the UX owner for the Dialer, so removing Larissa's need info, but
> Larissa, you're welcome to comment of course.

Sorry for bikeshedding about the UX: I’m no UX engineer but as a module owner of the Settings app, I’m trying to keep the best possible UI consistency. I usually ping Larissa for all Settings-related UX issues (is she the UX owner for the Settings app?), and she’s always surprised me in a good way when it comes to organizing these items and keeping them as self-explanatory as possible. :-)
(In reply to Francis Djabri [:djabber] from comment #18)
> Created attachment 758058 [details]
> call settings
> 
> Updated screenshot without the VM icon

Done, PR updated according last UX input (no VM icon). Kaze, could you take a look please? Thanks!
Flags: needinfo?(kaze)
Comment on attachment 755349 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/10076

r=me for the Settings part, unless Larissa comes up with a last-minute proposal. :-)
Attachment #755349 - Flags: review?(kaze) → review+
(In reply to Fabien Cazenave [:kaze] from comment #20)
> Thanks for the quick feedback Francis!
> 
> (In reply to Francis Djabri [:djabber] from comment #17)
> > (In reply to Fabien Cazenave [:kaze] from comment #16)
> > > The code is OK for me, but I’m troubled by the UX (attachment 756870 [details]
> > > [details]):
> > >  • the point that initially worried me (= the “Voicemail” is not separated
> > > from the rest of the call settings) is still there;
> > 
> > It seems strange to break out Voicemail into a new sub-category if it only
> > contains one setting. Therefore, I agree with Jose's approach.
> 
> FTR, there are other examples like that in the Settings app, e.g. at the
> bottom of the Device information > More Information panel (= git commit /
> developer items); but I agree a new sub-category is not necessarily the best
> option…
> 
> My point was, it is not obvious for me that clicking on this new “Voicemail”
> item should call another panel.
> 
> For such cases we often rely on buttons (see the “More information” button
> in the “Device information” panel) — and if we used a button here, we
> /could/ use a simple `window.prompt()' call, like for the Bluetooth >
> “Rename my device” case. 

It seems strange to me that a button should drill down within a hierarchy. Generally buttons are used for launching actions, like "Check now" in the Device Info settings. 

Furthermore, if a button is used to drill down to the next level, then all the Call Forwarding items within the Call Settings should also be buttons for the sake of consistency, as all of these items take the user to another panel. However, a button for all of these items would be very strange indeed, especially as these buttons would need to contain dynamic information based on the currently set forwarding number. 

So the most consistent option in this case would be for the Voicemail setting to appear as the other settings options in this list - i.e., without a button, as shown in the attachment above. I've discussed this with Larissa and she's in agreement.    

> 
> (In reply to Francis Djabri [:djabber] from comment #17)
> > > Waiting for Larissa’s feedback before r+’ing.
> > 
> > I am the UX owner for the Dialer, so removing Larissa's need info, but
> > Larissa, you're welcome to comment of course.
> 
> Sorry for bikeshedding about the UX: I’m no UX engineer but as a module
> owner of the Settings app, I’m trying to keep the best possible UI
> consistency. I usually ping Larissa for all Settings-related UX issues (is
> she the UX owner for the Settings app?), and she’s always surprised me in a
> good way when it comes to organizing these items and keeping them as
> self-explanatory as possible. :-)

I'm also the UX owner for the Settings application, as well as for Comms, so please refer Settings needs infos to me, or flag firefoxos-ux-bugzilla@mozilla.com for need info and Stephany will make sure it gets to the right person. Whatever the case, I'll make sure that I continue refer to Larissa's expertise on Settings going forward :)
Guys, could we land this bugs or we are waiting for someone to comment here?
Jaoo, it’s OK from me but I still wait for ‘tienne’s r+.
Flags: needinfo?(kaze)
(In reply to Fabien Cazenave [:kaze] from comment #25)
> Jaoo, it’s OK from me but I still wait for ‘tienne’s r+.

Oops, sorry. I didn't realize I'm still need it before landing this works. Thanks!
Just want to echo Francis' comments -- we've considered the options and are ok with the current design since changing it creates more inconsistencies on this page. Francis will open a bug for some of the inconsistencies we've found :D I promise, we will eliminate all inconsistencies within settings over time!

Moving forward, Francis is taking over Settings since I have other work in Firefox to do. I'm happy to give my opinions in case there are questions though.
Comment on attachment 755349 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/10076

Made some comments on github for the Dialer part.
Please ask for r? again when those are addressed.

Thanks!
Attachment #755349 - Flags: review?(etienne)
Blocks: 881178
Comment on attachment 755349 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/10076

Etienne, comment addressed. Could you take a look please? Thanks!
Attachment #755349 - Flags: review+ → review?(etienne)
Comment on attachment 755349 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/10076

r=me for the dialer part, thanks!

Flagging :kaze for a formal r? on the Settings part.
Attachment #755349 - Flags: review?(kaze)
Attachment #755349 - Flags: review?(etienne)
Attachment #755349 - Flags: review+
(In reply to Etienne Segonzac (:etienne) from comment #30)
> Comment on attachment 755349 [details]
> Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/10076
> 
> r=me for the dialer part, thanks!

Thanks!
 
> Flagging :kaze for a formal r? on the Settings part.

I guess I deleted it, sorry. Anyway let's do things right and wait for kaze's formal r+.
Attachment #755349 - Flags: review?(kaze) → review+
https://github.com/mozilla-b2g/gaia/commit/4addf3f4fe3852abc71da7766efe741601250d9f
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 4addf3f4fe3852abc71da7766efe741601250d9f
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(josea.olivera)
This bug was fixed on top of the changes introduced in bug 857105. I could fix the conflict or request leo+ flag for bug 857105. Waiting for ni? requested at :rik.
Flags: needinfo?(josea.olivera)
Blocks: 882057
Setting status-b2g-v1.1hd flag as affected too.
Uplifted 4addf3f4fe3852abc71da7766efe741601250d9f to:
v1-train: 53f002479c651562f4f4b135b2dcb16b9e6a970f
1.1hd: 53f002479c651562f4f4b135b2dcb16b9e6a970f
This bug adds three strings to apps/settings/locales/settings.en-US.properties

Please add a localization note telling what the term "Voicemail" refers to. Is "Voicemail Number" the telephone number of a person who left a voicemail message, or is it the telephone number you need to call to listen to your voicemail?
Verified fixed on 

Build ID: 20130806071254
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 4c1a20570e20f64782ba170c14604395c48f7381
Platform Version: 18.1

When user calls voicemail user is notify that user is call voice mail.
You need to log in before you can comment on or make changes to this bug.