[Buri][IOT]Low battery warning display abnormally

RESOLVED INVALID

Status

Firefox OS
Gaia
P2
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #459645 +++
 
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.111
 Firefox os  v1.0.1
 Mozilla build ID:20130518070208
 
 Created an attachment (id=419339)
 capture screen
 
 DEFECT DESCRIPTION:
 Low battery warning display abnormally
  REPRODUCING PROCEDURES:
 Power on the phone,Wait the phone battery lower than 10%,the phone display “battery almost empty”,wait 2s,the prompt disappear--K.O
 
  EXPECTED BEHAVIOUR:
 The prompt should be:
 1.keep showing until user plug charger 
 2.add prompt up window until user click "OK" to confirm he/she has already know it. 
 3.Pop up with sound
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #459645 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Updated

5 years ago
blocking-b2g: --- → tef?
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 754642 [details]
capture screen

Clone from brother
I don't agree with the UX proposal made in this bug. It would be persistent UI that would annoy the user in an unnecessary fashion. The overlay is enough to give the user notification of a low battery while not overly annoying them.

Asking UX to confirm. If so, this should be closed as invalid - by design.
Flags: needinfo?(firefoxos-ux-bugzilla)
Hi all,

I could not reproduce the case, "battery almost empty”,wait 2s,the prompt disappear--K.O" in a normal scenario.

However, if I rebooted the phone, after reboot, the "low battery warning" seemed to show for shorter than 5 secs.

Can someone confirm that "reboot" is a must-have step for this issue?
Thanks.
Flags: needinfo?(sync-1)

Comment 5

5 years ago
UX will address this after completing leo+, tef+ and tracking-b2g18+ bugs, which are the top UX priorities right now.
(In reply to Stephany Wilkes from comment #5)
> UX will address this after completing leo+, tef+ and tracking-b2g18+ bugs,
> which are the top UX priorities right now.

tef? are ranked as the highest priority in competition with tef+.

Comment 7

5 years ago
Jason: What does UX need to confirm? I'm sorry; it's hard to understand from the nature of the comment. Is it to clarify the expected behavior for the prompt?

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(kyee)
(In reply to Stephany Wilkes from comment #7)
> Jason: What does UX need to confirm? I'm sorry; it's hard to understand from
> the nature of the comment. Is it to clarify the expected behavior for the
> prompt?

Yes, that. I want to make sure the behavior is correct as i stated above.

Comment 9

5 years ago
(In reply to Jason Smith [:jsmith] from comment #3)
> I don't agree with the UX proposal made in this bug. It would be persistent
> UI that would annoy the user in an unnecessary fashion. The overlay is
> enough to give the user notification of a low battery while not overly
> annoying them.
> 
I agree with this.  No reason to ask the user to confirm low battery at all.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(kyee)
Resolution: --- → WONTFIX
triage with tef: this is not a blocker for OBs.
blocking-b2g: tef? → -

Comment 11

5 years ago
(In reply to Joe Cheng [:jcheng] from comment #10)
> triage with tef: this is not a blocker for OBs.

when will it be fixed?
Status: RESOLVED → REOPENED
blocking-b2g: - → leo?
Resolution: WONTFIX → ---

Updated

5 years ago
Flags: needinfo?(sync-1)
(In reply to Cheng-An, XIONG from comment #11)
> (In reply to Joe Cheng [:jcheng] from comment #10)
> > triage with tef: this is not a blocker for OBs.
> 
> when will it be fixed?

Please see comment 9. UX already made a decision that this was not a good idea to do. Which makes this not a valid bug.
Status: REOPENED → RESOLVED
blocking-b2g: leo? → ---
Last Resolved: 5 years ago5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.