Install gstreamer-ffmpeg package on linux test boxes

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
11 months ago

People

(Reporter: eflores, Assigned: rail)

Tracking

Details

Attachments

(1 attachment)

We need to be able to test gstreamer with mp4 support, so we need the gstreamer-ffmpeg package on the test boxes.

There appears to be a package for it in repoforge (some information on it at [1]) which appears to be reasonably standalone.

[1] http://pkgs.org/centos-6-rhel-6/repoforge-x86_64/gstreamer-ffmpeg-0.10.11-1.el6.rf.x86_64.rpm.html
Actually, if the linux test slaves are all ubuntu, the gstreamer0.10-ffmpeg package should pull down everything that's needed.
The full list of Ubuntu packages needed are:
 - libgstreamer0.10-0
 - gstreamer0.10-plugins-base
 - gstreamer0.10-ffmpeg
One last one
 - gstreamer0.10-plugins-good
Aaaaand one last last one:
 - gstreamer0.10-plugins-ugly
rail, could you take this on, or make some notes on how this should be done ?
Flags: needinfo?(rail)
(Assignee)

Comment 6

6 years ago
(In reply to Nick Thomas [:nthomas] from comment #5)
> rail, could you take this on, or make some notes on how this should be done ?

Sure
Assignee: nobody → rail
Flags: needinfo?(rail)
(Assignee)

Comment 7

6 years ago
Attachment #760861 - Flags: review?(dustin)
Comment on attachment 760861 [details] [diff] [review]
gstreamer packages for ubuntu slaves

Review of attachment 760861 [details] [diff] [review]:
-----------------------------------------------------------------

::: modules/packages/manifests/gstreamer.pp
@@ +5,5 @@
> +    case $::operatingsystem {
> +        Ubuntu: {
> +            package {
> +                ["gstreamer0.10-ffmpeg", "gstreamer0.10-plugins-base",
> +                 "gstreamer0.10-plugins-good", "gstreamer0.10-plugins-ugly"]:

We don't need gstreamer0.10-plugins-bad? ;)
Attachment #760861 - Flags: review?(dustin) → review+
(Assignee)

Comment 9

6 years ago
Comment on attachment 760861 [details] [diff] [review]
gstreamer packages for ubuntu slaves

https://hg.mozilla.org/build/puppet/rev/65062fc6affd

(In reply to Dustin J. Mitchell [:dustin] from comment #8)
> We don't need gstreamer0.10-plugins-bad? ;)

Those are so bad that we have 2 of thems: bad0 and bad1 :)
Attachment #760861 - Flags: checked-in+
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering

Updated

11 months ago
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.