Remove Vivo bookmarks in the browser

RESOLVED DUPLICATE of bug 840011

Status

Firefox OS
Gaia::Browser
RESOLVED DUPLICATE of bug 840011
5 years ago
5 years ago

People

(Reporter: brg, Assigned: gasolin@mozilla.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Remove Vivo bookmarks info from the bookmarks in the browser.
you can reproduce this issue with unagi device in v1.0.1 and v1-train.

Steps to reproduce:
open browser
Create new tab
Go to bookmarks option and there will be 3 vivo bookmarks.

Please remove this 3 bookmarks.
I thought there was a reason why we had these Vivo bookmarks. Can't remember why, but there was a reason for having them.
(In reply to Jason Smith [:jsmith] from comment #1)
> I thought there was a reason why we had these Vivo bookmarks. Can't remember
> why, but there was a reason for having them.

Adding ni on Ben to check if he remembers. Wouldn't it be better replacing it with some Mozilla Bookmarks?
blocking-b2g: tef? → tef+
Flags: needinfo?(bfrancis)
(Assignee)

Comment 3

5 years ago
Why tef+ ?

Currently Bookmarks are already customized to spain and latam bookmarks via our customization distribution, it means tef rom wont be shipped with these 3 bookmarks.
So it's not matter to current ROM Certify process.


But I thinks its a good thing to provide some sensible default bookmarks for gaia repo.
Flags: needinfo?(dcoloma)
Can we check if all the partners are already replacing the default bookmarks for the target markets? If that is the case, I agree we should not block on this one. Who can check this?
Flags: needinfo?(dcoloma)
Amelie should confirm on her end
Flags: needinfo?(mei.kong)
(Assignee)

Updated

5 years ago
Assignee: nobody → gasolin
(Assignee)

Comment 6

5 years ago
I think it's good to remove from default, but may not block as tef+

I'll send PR first due to the urgency of tef+.
r? to Ben and let him decide.
(Assignee)

Comment 7

5 years ago
Created attachment 755225 [details]
pull request redirect to github
Attachment #755225 - Flags: review?(bfrancis)
Can partner customization include overriding, or removing these defaults?  If yes, this is not a blocker.
(In reply to lsblakk@mozilla.com [:lsblakk] from comment #8)
> Can partner customization include overriding, or removing these defaults? 
> If yes, this is not a blocker.

Yes. The bookmarks are set at build time as part of customisation, these are just the defaults in the applications-data.js file. We could pick different defaults but this shouldn't be tef+
blocking-b2g: tef+ → tef?
Flags: needinfo?(bfrancis)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 840011

Updated

5 years ago
blocking-b2g: tef? → ---
Partners have confirmed they are modifying them. 

I do not have any issue with keeping them, at the end of the day, they are TEF Bookmarks, but I think it would be good for the project to have generic bookmarks. Up to you if you want to nominate for leo or request approval.
Flags: needinfo?(mei.kong)
Comment on attachment 755225 [details]
pull request redirect to github

Thanks for the patch Fred, we're waiting on product input on what the defaults should be in bug 840011 but you could move this patch to that bug in case we decide to just clear them.
Attachment #755225 - Flags: review?(bfrancis)
You need to log in before you can comment on or make changes to this bug.