Closed Bug 876703 Opened 7 years ago Closed 7 years ago

Browser invocation from SMS is not working with URLs of type: http://

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 verified)

VERIFIED FIXED
1.1 QE3 (26jun)
blocking-b2g leo+
Tracking Status
b2g18 --- verified

People

(Reporter: oteo, Assigned: rexboy)

References

()

Details

Attachments

(2 files)

Sending or receiving an SMS with an URL of this type (using http://) http://www.mozilla.org or http://mozilla.org is not working

When you send or receive a SMS with this kind of URL, it seems that the system recognizes it as a valid URL, as it is underlined, but when you tap on it, the browser is not launched so you can not access to the link.

Otherwise if you send or receive an SMS with an URL of this type: www.mozilla.org is working without problem.

tested with v1-train
Gecko:c930902
Gaia:a6d5dc7
Device:unagi
Requesting leo+, as this seems to be a regression. LG requested the implementation of this US (bug 838005) and need to be fixed.

In e-mail the access to this type of URL is working fine
blocking-b2g: --- → leo?
I forgot to mention that for reproducing this fault you should send an SMS with just one URL, I am suffering strange behaviours and sometimes if I mixed several clickable contents it's not always happening...
blocking-b2g: leo? → leo+
Priority: -- → P2
Target Milestone: --- → 1.1 QE3
Assignee: nobody → rexboy
Attached image screenshot
If the first character is uppercase in the url, it will not work.
As the attachment, "http://mozilla.org" can be tapped, but "Http://mozilla.org" can not be tapped.
Attached file patch
It's just because the filter set for activity doesn't apply on URLs with upper-cased protocol. This should happen for any apps trying to open URL with browser I think..
Attachment #757294 - Flags: review?(bfrancis)
(In reply to GaryChen [:GaryChen] (MoCo-TW) from comment #3)
> Created attachment 756462 [details]
> screenshot
> 
> If the first character is uppercase in the url, it will not work.
> As the attachment, "http://mozilla.org" can be tapped, but
> "Http://mozilla.org" can not be tapped.

you are right, but it only happens with URL starting with Http:// 
If for example I am sending Www.mozilla.org (the first character is uppercase) I can open the URL when I tap on it.


Besides (perhaps I should open a new bug for it) after sending an SMS with an URL that does not work, when I compose other SMS and try to send it the "send" button does not work. Only I am able to send another SMS, deleting the last sent SMS with the failed URL...
Component: Gaia::SMS → Gaia::Browser
Comment on attachment 757294 [details]
patch

Thanks for the patch. r+me.
Attachment #757294 - Flags: review?(bfrancis) → review+
Thanks for reviewing Ben!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Uplifted 9d36cc1213e9dadd74b29babb55518bfd919963f to:
v1-train: e780e9345e818c92652c028ca7a2fc7d4775b219
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
Executed test case in MozTrap https://moztrap.mozilla.org/manage/case/8745/ and verified fixed on:
Device: Leo phone
Build Identifier: 20130621070212
Update channel: leo/1.1/nightly
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a34f6d62cb05
Gaia: cca61224e6df8e9f7e450d77cb6a8cf91029be641371823447
Git commit info: 2013-06-21 14:04:07
OS version: 1.1.0.0-prerelease
Status: RESOLVED → VERIFIED
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
You need to log in before you can comment on or make changes to this bug.