Closed Bug 876764 Opened 8 years ago Closed 7 years ago

Entering customization mode with open customization tab breaks it

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: morpheus3k+bugzilla, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M6])

Attachments

(1 file)

STR:
1. Open some tabs
2. Open Customization mode via Menu Panel
3. Switch to another tab
4. Open Customization mode via Menu Panel (again)

Expected:
Switch to customization tab.

Actual:
Switch to customization tab, but breaks the mode.
Whiteboard: [Australis:M?]
Can't reproduce this on current OS X builds. Can you try this build? I suspect Jared's fix for undo close tab fixed this: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/ux-macosx64/1369751904/firefox-24.0a1.en-US.mac.dmg
(In reply to :Gijs Kruitbosch from comment #1)
> Can't reproduce this on current OS X builds. Can you try this build? I
> suspect Jared's fix for undo close tab fixed this:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/ux-macosx64/
> 1369751904/firefox-24.0a1.en-US.mac.dmg

Egh, scratch that, I can reproduce weirdness, at the very least.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
First to review wins!

I had this in my patch for the "undo close tab" bug but the patch worked fine without it. It seems that the change was necessary after all :)
Attachment #755021 - Flags: review?(mconley)
Attachment #755021 - Flags: review?(gijskruitbosch+bugs)
OS: Mac OS X → All
Hardware: x86 → All
Comment on attachment 755021 [details] [diff] [review]
Patch

Oh yeah, totally. How did that stuff get down there after the beforecustomization event fires? :/

I have a sneaking suspicion that was my bad. r=me.
Attachment #755021 - Flags: review?(mconley) → review+
Attachment #755021 - Flags: review?(gijskruitbosch+bugs)
https://hg.mozilla.org/projects/ux/rev/b7ab1c274cf5
Whiteboard: [Australis:M?] → [Australis:M?][fixed-in-ux]
Whiteboard: [Australis:M?][fixed-in-ux] → [Australis:M6][fixed-in-ux]
https://hg.mozilla.org/mozilla-central/rev/b7ab1c274cf5
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M6][fixed-in-ux] → [Australis:M6]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.