Use published date instead of updated

RESOLVED FIXED in Thunderbird 24.0

Status

MailNews Core
Feed Reader
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: realname, Assigned: alta88)

Tracking

Thunderbird 24.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

4.37 KB, patch
Magnus Melin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0 SeaMonkey/2.15.2 (Beta/Release)
Build ID: 20130203013604

Steps to reproduce:

Would be great if Thunderbird could use the published date in an Atom feed instead of the updated date if there's an empty one.

E. g. http://www.techstage.de/rss.xml

Contains for an entry the following elements:
		<published>2013-05-28T19:36:00+02:00</published>
		<updated></updated>

Unfortunately, Thunderbird is displaying the fetching time as article time. Would be great to have the published date as alternative as it sounds logical that a never-updated article has no updated-date.
(Reporter)

Updated

4 years ago
Version: unspecified → 17
(Assignee)

Comment 1

4 years ago
it's because there's an <updated> tag, but it's empty.  but yes, it would be nice to check that..
Status: UNCONFIRMED → NEW
Component: Folder and Message Lists → Feed Reader
Ever confirmed: true
OS: Linux → All
Product: Thunderbird → MailNews Core
Hardware: x86_64 → All
(Assignee)

Comment 2

4 years ago
Created attachment 754967 [details] [diff] [review]
patch


and `here it is.
Assignee: nobody → alta88
Attachment #754967 - Flags: review?(mkmelin+mozilla)

Comment 3

4 years ago
Comment on attachment 754967 [details] [diff] [review]
patch

Review of attachment 754967 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. r=mkmelin
Attachment #754967 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/3a04eb8b4f83
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 24.0
(Reporter)

Comment 5

4 years ago
Wow - many thanks for the fast implementation. Cannot wait to get the update ;)
You need to log in before you can comment on or make changes to this bug.