Cannot access re-review queue

VERIFIED FIXED in 2013-08-13

Status

P2
normal
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: amyt, Assigned: kngo)

Tracking

unspecified
2013-08-13
x86
Mac OS X

Details

(Whiteboard: [qa+])

(Reporter)

Description

5 years ago
When I go to https://marketplace.firefox.com/reviewers/themes/queue/rereview, I get an error page that says, "Oops! We had an error. We'll get to fixing that soon. You can try refreshing the page, or try again later."

This is what I see when I'm in the review queue: http://i.imgur.com/VWhLqgK.png

I am in the Persona Reviewers and Senior Persona Reviewers groups
Severity: normal → blocker
Priority: -- → P1
Target Milestone: --- → 2013-05-30
The re-review queue is empty.  Not a blocker for push.
Severity: blocker → normal
Priority: P1 → P2
(Assignee)

Comment 2

5 years ago
https://github.com/mozilla/zamboni/commit/c4bc9f691ea9e6acb24b2e49ac7740c7e0fc11d0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: 2013-05-30 → 2013-06-06

Comment 3

5 years ago
verified fixed @ https://marketplace-dev.allizom.org/reviewers/themes/queue/rereview
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

5 years ago
I completed a batch of 7 reviews in the re-review queue, clicked Commit, and got the Oops page.

And the Oops page remains when I try to return to https://marketplace.firefox.com/reviewers/themes/queue/rereview
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

5 years ago
https://github.com/mozilla/zamboni/commit/f7f705916feb319779ffdc67469b61463d932d3f

Still not sure how this happened, but this script will either help debug or miraculously fix an edge case.
(Assignee)

Updated

5 years ago
Target Milestone: 2013-06-06 → 2013-06-27
(Assignee)

Comment 6

5 years ago
Ran the command and seems working for now on prod.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
The image is not updated, and the version on the edit page is pixelated.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Target Milestone: 2013-06-27 → 2013-07-18
Looks like it's because of:

DoesNotExist: Addon matching query does not exist.

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "waffle/decorators.py", line 36, in _wrapped_view
    return view(request, *args, **kwargs)
  File "amo/decorators.py", line 32, in wrapper
    return func(request, *args, **kw)
  File "editors/views.py", line 74, in wrapper
    return f(request, *args, **kw)
  File "mkt/reviewers/views_themes.py", line 113, in themes_queue_rereview
    return _themes_queue(request, rereview=True)
  File "mkt/reviewers/views_themes.py", line 136, in _themes_queue
    'tab': 'flagged' if flagged else 'rereview' if rereview else 'pending'
  File "jingo/__init__.py", line 80, in render
    rendered = render_to_string(request, template, context)
  File "jingo/__init__.py", line 98, in render_to_string
    return template.render(**get_context())
  File "jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)
  File "/data/www/addons.mozilla.org/zamboni/mkt/reviewers/templates/reviewers/themes/queue.html", line 6, in top-level template code
    {% set title_text = _('Theme Review Queue') %}
  File "/data/www/addons.mozilla.org/zamboni/mkt/reviewers/templates/reviewers/base.html", line 1, in top-level template code
    {% extends 'developers/skeleton_impala.html' %}
  File "/data/www/addons.mozilla.org/zamboni/mkt/developers/templates/developers/skeleton_impala.html", line 114, in top-level template code
    {% block main_content %}
  File "/data/www/addons.mozilla.org/zamboni/mkt/developers/templates/developers/skeleton_impala.html", line 117, in block "main_content"
    {% block content %}{% endblock %}
  File "/data/www/addons.mozilla.org/zamboni/mkt/reviewers/templates/reviewers/themes/queue.html", line 109, in block "content"
    {% include 'reviewers/themes/themes.html' %}
  File "/data/www/addons.mozilla.org/zamboni/mkt/reviewers/templates/reviewers/themes/themes.html", line 5, in top-level template code
    {% set header_url = theme.header_url %}
  File "jinja2/environment.py", line 371, in getattr
    return getattr(obj, attribute)
  File "editors/models.py", line 680, in header_url
    return self.theme._image_url(self.header or self.theme.header)
  File "addons/models.py", line 1717, in _image_url
    return self.get_mirror_url(filename)
  File "addons/models.py", line 1723, in get_mirror_url
    host = (settings.PRIVATE_MIRROR_URL if self.addon.is_disabled
  File "django/db/models/fields/related.py", line 350, in __get__
    rel_obj = qs.get(**params)
  File "django/db/models/query.py", line 366, in get
    % self.model._meta.object_name)
(Assignee)

Comment 9

5 years ago
Yeah, I pushed a patch that should prevent future occurrences of this.

We just now ran a command to clean up the queue. Hopefully, the dam holds.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

5 years ago
I need help from QA testing the theme rereview queue on production.

Steps to Reproduce:

1. Submit a theme (https://addons.mozilla.org/en-US/developers/theme/submit)
2. Get the theme approved (https://marketplace.firefox.com/reviewers/themes/queue/single/<THEME_SLUG>)
3. Reupload the theme (https://addons.mozilla.org/en-US/developers/theme/<THEME_SLUG>/edit)
4. Approve the reuploaded theme (https://marketplace.firefox.com/reviewers/themes/queue/single/<THEME_SLUG>)

Expected Results:

All the images are present and look normal on the Edit Listing and detail pages and install correctly.

Actual Results:

The images may be missing or pixelated on the Edit Listing and detail pages, and do no install correctly.

Notes:

It may be intermittent. amyt has been able to consistently reproduce. I did a few trials on my own test theme and could not reproduce. 

Works fine on -dev.
Whiteboard: [qa+]
Kevin - you are a theme reviewer in production now.  Do what you gotta do
Target Milestone: 2013-07-18 → 2013-08-08
(Assignee)

Comment 12

5 years ago
I need to be a Senior Persona Reviewer to access the re-review queue. Even then it'd be hard to test unless I could review my own themes which I need admin to do.
(Assignee)

Comment 13

5 years ago
This fixes re-reviews when the artist re-uploads only the header or only the footer (rather than both header and footer).

https://github.com/mozilla/zamboni/commit/93a74b790eea8eca4448b2ec16ad039a63ea1447

Have to wait until production to verify. -dev's celery is backed up, making it difficult to re-upload themes right now.
(Assignee)

Comment 14

5 years ago
I'm all-in.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 15

5 years ago
I cannot verify this bug as celery is clogged up in prod. My theme is not even showing up in the re-review queue. Also, images are not showing up for my themes blocking me from checking if those things are pixelated.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 16

5 years ago
It should verifiable now that Celery is no longer clogged.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Target Milestone: 2013-08-06 → 2013-08-13

Comment 17

5 years ago
https://marketplace.firefox.com/reviewers/themes/queue/rereview loads fine and I see no tracebacks or pixelated themes
Status: RESOLVED → VERIFIED
(Assignee)

Comment 18

5 years ago
https://github.com/mozilla/zamboni/pull/1094 More permanent fix.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.