Closed Bug 876884 Opened 10 years ago Closed 4 years ago

crash in webrtc::videocapturemodule::VideoCaptureDS::SetCameraOutput

Categories

(Core :: WebRTC, defect, P5)

22 Branch
x86
Windows 7
defect

Tracking

()

RESOLVED DUPLICATE of bug 1502172

People

(Reporter: jsmith, Assigned: jesup)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-e9cbcc70-420a-41ef-a55d-7881e2130519 .
============================================================= 

Frame 	Module 	Signature 	Source
0 	xul.dll 	webrtc::videocapturemodule::VideoCaptureDS::SetCameraOutput 	media/webrtc/trunk/webrtc/modules/video_capture/windows/video_capture_ds.cc:252
1 	xul.dll 	webrtc::videocapturemodule::VideoCaptureDS::Init 	media/webrtc/trunk/webrtc/modules/video_capture/windows/video_capture_ds.cc:136
2 	xul.dll 	webrtc::videocapturemodule::VideoCaptureImpl::Create 	media/webrtc/trunk/webrtc/modules/video_capture/windows/video_capture_factory_windows.cc:32
3 	xul.dll 	webrtc::ViECapturer::Init 	media/webrtc/trunk/webrtc/video_engine/vie_capturer.cc:178
4 	xul.dll 	webrtc::ViECapturer::CreateViECapture 	media/webrtc/trunk/webrtc/video_engine/vie_capturer.cc:162
5 	xul.dll 	webrtc::ViEInputManager::CreateCaptureDevice 	media/webrtc/trunk/webrtc/video_engine/vie_input_manager.cc:235
6 	xul.dll 	webrtc::ViECaptureImpl::AllocateCaptureDevice 	media/webrtc/trunk/webrtc/video_engine/vie_capture_impl.cc:121
7 	xul.dll 	mozilla::MediaEngineWebRTCVideoSource::Allocate 	content/media/webrtc/MediaEngineWebRTCVideo.cpp:245
8 	xul.dll 	mozilla::GetUserMediaRunnable::ProcessGetUserMedia 	dom/media/MediaManager.cpp:739
9 	xul.dll 	mozilla::GetUserMediaRunnable::Run 	dom/media/MediaManager.cpp:600
10 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
11 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:265
12 	nss3.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:395
13 	nss3.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:90
14 	msvcr100.dll 	_callthreadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:314
15 	msvcr100.dll 	_threadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:292
16 	kernel32.dll 	BaseThreadInitThunk 	
17 	ntdll.dll 	__RtlUserThreadStart 	
18 	ntdll.dll 	_RtlUserThreadStart
_outputCapturePin must be null...

VideoCaptureDS::Init() doesn't check the result of GetOutputPin() (or GetInputPin()), which may be the root cause of the crash.

This would be an upstream bug in webrtc.org code

Bas, should the code there be checking the results?  Can you sanity-check the Init() code?
Assignee: nobody → rjesup
Flags: needinfo?(bas)
Whiteboard: [WebRTC] [blocking-webrtc-]
I'm going to assume this question is no longer relevant :). Sorry!
Flags: needinfo?(bas)
Still happening:
https://crash-stats.mozilla.com/report/index/e13373f2-3c57-4e31-92e8-c58bb2150609
but very low frequency; null-deref.
backlog: --- → webRTC+
Rank: 45
OS: Windows NT → Windows 7
Priority: -- → P4
QA Contact: jsmith
Whiteboard: [WebRTC] [blocking-webrtc-]
Crash Signature: [@ webrtc::videocapturemodule::VideoCaptureDS::SetCameraOutput(webrtc::VideoCaptureCapability const&)] → [@ webrtc::videocapturemodule::VideoCaptureDS::SetCameraOutput(webrtc::VideoCaptureCapability const&)] [@ webrtc::videocapturemodule::VideoCaptureDS::SetCameraOutput]
Mass change P4->P5 to align with new Mozilla triage process.
Priority: P4 → P5
(In reply to Randell Jesup [:jesup] from comment #1)
> _outputCapturePin must be null...
> 
> VideoCaptureDS::Init() doesn't check the result of GetOutputPin() (or
> GetInputPin()), which may be the root cause of the crash.
> 
> This would be an upstream bug in webrtc.org code

This speculative fix has been fixed in bug 1502172 and merged upstream.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.