Remove the "Basic ECC" vs. "Extended ECC" distinction in the version string in lib/nss/nss.h

RESOLVED DUPLICATE of bug 978637

Status

NSS
Libraries
P2
minor
RESOLVED DUPLICATE of bug 978637
5 years ago
4 years ago

People

(Reporter: Wan-Teh Chang, Assigned: Robert Relyea)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
With the work done in NSS 3.15 (such as bug 838778 and bug 857882),
the files that make up the main NSS package (libnss3.so, libssl3.so,
and libsmime3.so) no longer test the NSS_ECC_MORE_THAN_SUITE_B macro:

http://mxr.mozilla.org/nss/search?string=NSS_ECC_MORE_THAN_SUITE_B

So the "Basic ECC" vs. "Extended ECC" distinction no longer makes
sense, and should be removed from the NSS_VERSION macro in lib/nss/nss.h.

The files still test the NSS_ENABLE_ECC macro, so we still need the
ECC vs. no-ECC distinction in lib/nss/nss.h.
(Reporter)

Updated

5 years ago
Target Milestone: 3.15.1 → 3.15.2
(Reporter)

Updated

4 years ago
Target Milestone: 3.15.2 → 3.16
(In reply to Wan-Teh Chang from comment #0)
> The files still test the NSS_ENABLE_ECC macro, so we still need the
> ECC vs. no-ECC distinction in lib/nss/nss.h.

I propose that we fix bug 978637 in NSS 3.17 and then completely remove the distinction between the various levels of ECC support in the version string.
(Reporter)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 978637
You need to log in before you can comment on or make changes to this bug.