Font is messy on ITTF President Forum

RESOLVED INVALID

Status

()

Core
Layout: Text
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: dusty-2011, Unassigned)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 755109 [details]
screenshot in Firefox 21.0 with HWA enabled

The font in Firefox 21.0 is messy on the ITTF President Forum. An example page: http://www.ittf.com/stories/Forum_detail.asp?ID_Forumn=75&

The font looks the same with HWA enabled as it does with HWA disabled, in both cases messy. The spacing between letters is too narrow, causing weird looking letters.

The font looks fine in IE9 and Chrome 27.

I have added a screenshot of this page to this report as an attachment:
- screenshot in Firefox 21.0 with HWA enabled

Be sure to view the screenshot at original size.
(Reporter)

Comment 1

5 years ago
Created attachment 755110 [details]
screenshot in firefox with HWAdisabled
(Reporter)

Comment 2

5 years ago
Created attachment 755111 [details]
screenshot in IE9 with HWA enabled
(Reporter)

Comment 3

5 years ago
Created attachment 755114 [details]
Screenshot in Chrome 27 with HWA enabled

The small letters on the right sidebar do not look perfect in Chrome, but they are much better than in Firefox.

Comment 4

5 years ago
the site used negative value of letter-spacing.
It seems letter-spacing: normal or letter-spacing: 0 solves the problem.

Updated

5 years ago
Component: Untriaged → Layout: Text
Product: Firefox → Core
Firefox is rendering the page as specified. Applying letter-spacing:-1pt to text with font-size:10pt is a recipe for extremely "cramped" letters.

It looks like Chrome does some kind of rounding of the letter-spacing value, so that -1pt (as specified in the page's CSS) becomes -1px, although the "correct" conversion would have been -1.333333px. As such, it isn't applying as much negative letter-spacing as Firefox, which uses the true, unrounded value.

If the page had specified -1px, the Chrome and Firefox renderings would be more similar.

As for IE10, it only looks "OK" because that page is processed in "quirks" mode by default, which seems to ignore the letter-spacing. Switch it to Standards mode (F12, Alt-S) and it gives text that looks every bit as overcrowded as Firefox.

Conclusion: not a Gecko bug, just a poorly styled site.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.