If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

500 internal server errors a plenty

RESOLVED WONTFIX

Status

Webtools
BzAPI
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: jhford, Assigned: gerv)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I'm trying to load and comment on bugs using bzapi and for a couple of hours, i've been seeing a bunch of 500 errors on the api requests.  They are taking a long time before finally returning 500.  Sometimes it works, sometimes it doesn't.

Example query: https://api-dev.bugzilla.mozilla.org/1.3/bug/869851?include_fields=_all

Updated

4 years ago
OS: Mac OS X → All
Hardware: x86 → All
I saw FastCGI errors in httpd error log but I haven't restarted apache:

[Tue May 28 21:58:15 2013] [error] [client <IP redacted> ] FastCGI: incomplete headers (0 bytes) received from server "/var/www/1.3/script/bugzilla_api_fastcgi.pl"
[Tue May 28 21:58:15 2013] [warn] FastCGI: server "/var/www/1.3/script/bugzilla_api_fastcgi.pl" (pid 25300) terminated by calling exit with status '1'
[Tue May 28 21:58:17 2013] [warn] FastCGI: server "/var/www/1.3/script/bugzilla_api_fastcgi.pl" restarted (pid 25308)
(Assignee)

Comment 2

4 years ago
I'm looking into this right now.

Gerv
(Assignee)

Comment 3

4 years ago
I think the 500 errors are caused by a timeout. BzAPI is having trouble processing the data.  jhford's query causes BzAPI to request all the data about the bug from Bugzilla, including the attachment data. In the case of the sample URL you give, this is 6Mb worth. Without having looked into it, I'm sure BzAPI is not as efficient as it could be in avoiding unnecessary decodes and copies of that data.

The query https://api-dev.bugzilla.mozilla.org/1.3/bug/869851 does not request attachment data, and returns much more quickly.

So I suggest that you are more careful about what fields you request, and your problem should go away :-)

Gerv
(Assignee)

Comment 4

4 years ago
ashish: is that OK?

Gerv
(In reply to Gervase Markham [:gerv] from comment #4)
> ashish: is that OK?
> 
> Gerv

Yep, that totally sounds fine to me. I've no objections to closing this bug out.
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.