The last received file may be deleted if the user denies the incoming file transfer request

RESOLVED FIXED

Status

Firefox OS
Bluetooth
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ericchou, Assigned: ericchou)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, firefox22 wontfix, firefox23 wontfix, firefox24 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

Details

(Whiteboard: [fixed-in-birch], URL)

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
build: latest b2g18/v1-train
STR:
1. Send a photo from other devices to B2G device and make sure it succeeded.
2. Send the same photo again. When the receiving confirmation dialog pops up, press 'Deny' to reject this transfer request.
3. Use adb to check the file received in 1. It would be deleted magically.
(Assignee)

Comment 1

5 years ago
Created attachment 755244 [details] [diff] [review]
patch 1: v1: Clear mDsFile after the OPP connection is dropped
Assignee: nobody → echou
Attachment #755244 - Flags: review?(gyeh)
Comment on attachment 755244 [details] [diff] [review]
patch 1: v1: Clear mDsFile after the OPP connection is dropped

Review of attachment 755244 [details] [diff] [review]:
-----------------------------------------------------------------

This patch should be for b2g18. Please provide another patch for m-c. Thanks.
Attachment #755244 - Flags: review?(gyeh) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/projects/birch/rev/1d4682af6cae
Whiteboard: [fixed-in-birch]
(Assignee)

Comment 4

5 years ago
Nominate as leo+ since this is also caused by bug 858416.
Blocks: 858416
blocking-b2g: --- → leo?
https://hg.mozilla.org/mozilla-central/rev/1d4682af6cae
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
triage: leo+, regression per comment #4
blocking-b2g: leo? → leo+
Keywords: regression
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-b2g18/rev/4f318822e72c
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → wontfix
https://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/4f318822e72c
status-b2g18-v1.0.0: --- → wontfix
status-b2g-v1.1hd: --- → fixed
status-firefox22: --- → wontfix
status-firefox23: --- → wontfix
status-firefox24: --- → fixed

Updated

5 years ago
Flags: in-moztrap?

Updated

5 years ago
Flags: in-moztrap? → in-moztrap+
QA Contact: amiller
You need to log in before you can comment on or make changes to this bug.