Nightly uses the same profile as Release and other branches

RESOLVED DUPLICATE of bug 1373244

Status

()

RESOLVED DUPLICATE of bug 1373244
6 years ago
a year ago

People

(Reporter: callow.mark, Unassigned)

Tracking

22 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130521223249

Steps to reproduce:

I had FF22 (beta channel) running and set as my default browser.

I installed nightly FF24a1. The web page says clearly "for testing purposes only".

During the install I unchecked the box "Make nightly my default browser."


Actual results:

1. Nightly was made my default browser and appeared in the Windows Start Menu.

2. When I told the installer to run Nightly, I was told Nightly was already running.

3. After exiting FF22 and running Nightly it became clear Nightly was using my FF22 profile.

3. I therefore uninstalled Nightly. After uninstalling Nightly
    - Opera is shown as the default browser in the Start Menu
    - FF22 does not appear in the list of browsers shown in Start Menu properties
    - but FF22 believes it is the default browser so I can't fix the Start Menu


Expected results:

1. Nightly should not have become the default browser.

2. Nightly should have remained wholly separate from my FF22 installation; it should not touch the FF22 profile. I don't want it wrecked by "test only" software.

Until this bug is fixed, I will never again install Nightly on Windows.

FF Mobile on Android keeps the channels separate. I can happily have Release, Beta and Nightly all installed and all operate independently of each other. That's what I want on Windows. FF Sync can be used to share the profile between them, if desired.
Workaround:
1. Temporarily set other browsers as default via [Set Program Access and Defaults]. (Firefox options will not work because Firefox will consider it is already default.)
2. Make Firefox default again via [Tools]-[Options]-[Advanced]-[General] in Firefox. (SPAD will not work because only Nightly will be listed.)
Status: UNCONFIRMED → NEW
Component: Untriaged → Installer
Ever confirmed: true
I believe there is a previously reported duplicate of this bug filed several years ago that was resolved as wontfix due to this is provided by Windows settings and these settings are not flexible enough as they are on Android to provide what you are asking for. As noted in comment #1 you can set the other as default and the fact this has been reported so infrequently also shows this is at best a minor issue that is easily dealt with.

Moving the bug to the proper component for the profile issue.
Component: Installer → Startup and Profile System
Product: Firefox → Toolkit
Whiteboard: [DUPEME]
We should at least activate [Make Firefox the default browser] button without changing the default to another browser first. It should be detectable because the file system path of the default browser is overwritten with another value.
(In reply to Masatoshi Kimura [:emk] from comment #3)
> We should at least activate [Make Firefox the default browser] button
> without changing the default to another browser first. It should be
> detectable because the file system path of the default browser is
> overwritten with another value.
Agreed and I will look into it.
(Reporter)

Comment 5

6 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #2)
> I believe there is a previously reported duplicate of this bug filed several
> years ago that was resolved as wontfix due to this is provided by Windows
> settings and these settings are not flexible enough

Chrome manages to do it. I have 2 out of their 3 channels on the same system and they work independently.
(Reporter)

Comment 6

6 years ago
(In reply to Masatoshi Kimura [:emk] from comment #1)
> Workaround:
> 1. Temporarily set other browsers as default via [Set Program Access and
> Defaults]. (Firefox options will not work because Firefox will consider it
> is already default.)

Thanks for suggesting the workaround. I do not know what [Set Program Access and
Defaults] is referring to so I used another browser telling it to set itself as default. (I couldn't find the appropriate button in Opera or IE. I ended up doing it with Chrome.) After that I the Firefox button was activated so I could fix the problem.
(In reply to Mark Callow from comment #5)
> Chrome manages to do it. I have 2 out of their 3 channels on the same system
> and they work independently.

How did you install multiple Chrome channels simultaneously? I thought Chrome installer wouldn't even allow changing the install location. Chrome Canary doesn't allow making it default, so it should not have a problem.
Chrome used to prevent setting the Canary branch as default last I checked and when I talked to them about why a while back it was in part for this same reason.
(Reporter)

Comment 9

6 years ago
The 2 channels I have installed are Canary and Dev. Canary, which from the extremely limited descriptions provided seems equivalent to Nightly, is installed in a different location than the dev, beta or stable channels and uses its own profile. The Dev, beta and stable channels all install in the same place and use the same profile. All channels use the same executable name.

You are correct that Canary does not allow making it default, a not unreasonable limitation for such potentially unstable software.
(In reply to Mark Callow from comment #9)
> The 2 channels I have installed are Canary and Dev. Canary, which from the
> extremely limited descriptions provided seems equivalent to Nightly, is
> installed in a different location than the dev, beta or stable channels and
> uses its own profile. The Dev, beta and stable channels all install in the
> same place and use the same profile. All channels use the same executable
> name.
> 
> You are correct that Canary does not allow making it default, a not
> unreasonable limitation for such potentially unstable software.
It is also no unreasonable for the Firefox nightly to be set as default from my own and other people's experiences. Are you suggesting we should mirror the chrome Canary channel? Personally, I don't think it is needed or desired.
(Reporter)

Comment 11

6 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #10)
> Are you suggesting we should mirror the chrome Canary channel? Personally,
> I don't think it is needed or desired.

No. I am suggesting (requesting) that when the user tells you "don't make Nightly my default browser" that you do not do so and also that you do not use the default Firefox profile in that case.

Perhaps you need to add a second question about the profile, when there is already a FF installation on the system, in order to give the most flexibility.
(In reply to Mark Callow from comment #11)
> (In reply to Robert Strong [:rstrong] (do not email) from comment #10)
> > Are you suggesting we should mirror the chrome Canary channel? Personally,
> > I don't think it is needed or desired.
> 
> No. I am suggesting (requesting) that when the user tells you "don't make
> Nightly my default browser" that you do not do so
I'll file a bug specific for this issue and targeting what we are able to accomplish given the limitations on Windows.

> and also that you do not
> use the default Firefox profile in that case.
Profiles are covered by this bug.

> Perhaps you need to add a second question about the profile, when there is
> already a FF installation on the system, in order to give the most
> flexibility.
The installer doesn't deal with profiles so a second question in the installer is not going to happen.
Summary: Nightly takes over as default browser even when told not to → Nightly uses the same profile as Release and other branches
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 895030
Duplicate of bug: 1373244
You need to log in before you can comment on or make changes to this bug.