[Email] Long email id bubble in read mail page is out of the screen

RESOLVED FIXED

Status

P2
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mihai, Assigned: mihai)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18+ fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: [TD-26515],mozilla-triage, [LeoVB+])

Attachments

(2 attachments)

Created attachment 755323 [details]
Screenshot highlighting issue

+++ This bug was initially created as a clone of Bug #871449 +++

STR: Open Email App > Select an email whose address is long from Inbox/Sent/...

Expected Result: the long email address should be shown with ellipsis in peep bubble (same as for bug 871449)

Actual Result: the long email address overflows the width of the screen (see attached screenshot)
Created attachment 755346 [details]
Pull Request #10075 - Truncate long email addresses

Quick CSS solution to truncate long email addresses with ellipsis.
Attachment #755346 - Flags: review?(bugmail)
Comment on attachment 755346 [details]
Pull Request #10075 - Truncate long email addresses

So, right now we have a weird situation with the bubbles.  The composer bubbles end up with both msg-peep-bubble and cmp-peep-bubble on them.  I had requested psingapati try and refactor the style just into a general "peep-bubble" class in mail.css, but he ran into trouble.

Rather than duplicate the style, since both bubble types use "msg-peep-bubble", let's either just move the style directives in question into there or undertake the creation of the more generic class so we can avoid the duplication.  (msg-peep-bubble and cmp-peep-bubble should still exist for identification purposes, however)

Thanks!
Attachment #755346 - Flags: review?(bugmail)
Comment on attachment 755346 [details]
Pull Request #10075 - Truncate long email addresses

Thanks for the suggestions, Andrew!

I updated the patch creating a more generic "peep-bubble" class that takes care of text overflow and made the necessary changes to the styles -- this also fixes bug 871449 (overwrites the changes done there).
Attachment #755346 - Flags: review?(bugmail)
Comment on attachment 755346 [details]
Pull Request #10075 - Truncate long email addresses

Looks good!  Feel free to land.
Attachment #755346 - Flags: review?(bugmail) → review+
Status: NEW → ASSIGNED
Landed on master:
https://github.com/mozilla-b2g/gaia/commit/967459442a5d1630fe9049743bc495bf0540cb7f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 755346 [details]
Pull Request #10075 - Truncate long email addresses

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Email peep bubbles overflowing screen width
User impact if declined: Medium (visible for emails received from long addresses like 'notification+oec64jgdsi32@facebookmail.com')
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): Low (mainly CSS changes)
String or UUID changes made by this patch: No
Attachment #755346 - Flags: approval-gaia-v1?

Comment 7

5 years ago
Comment on attachment 755346 [details]
Pull Request #10075 - Truncate long email addresses

We're past the point of approval-gaia-v1 noms in 1.1's schedule. If you feel this is a critical blocker, please set blocking-b2g:leo+
Attachment #755346 - Flags: approval-gaia-v1? → approval-gaia-v1-

Comment 8

5 years ago
blocking-b2g:leo?*
Taking into account the details of comment 6, requesting blocking-b2g:leo
blocking-b2g: - → leo?
Leo is not in today's triage, this bug is not critical for the partners who attended. Leaving decision to leo.
Flags: needinfo?(leo.bugzilla.gaia)

Updated

5 years ago
Whiteboard: [TD-26515] → [TD-26515],mozilla-triage

Comment 11

5 years ago
Please uplift the patch to v1-train.
blocking-b2g: leo? → leo+
Flags: needinfo?(leo.bugzilla.gaia)
Uplifted 967459442a5d1630fe9049743bc495bf0540cb7f to:
v1-train: 64d75a37bb1d79e2a4d728fb81d1ced145844e3f
status-b2g18: --- → fixed

Updated

5 years ago
Whiteboard: [TD-26515],mozilla-triage → [TD-26515],mozilla-triage, [LeoVB+]
v1.1.0hd: 64d75a37bb1d79e2a4d728fb81d1ced145844e3f
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.