Table headers not associated when header is a td element with no scope

RESOLVED DUPLICATE of bug 704465

Status

()

RESOLVED DUPLICATE of bug 704465
5 years ago
5 years ago

People

(Reporter: Jamie, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
NVDA ticket: http://community.nvda-project.org/ticket/3244

Apparently, the HTML spec allows a cell listed in the headers attribute to be a td element instead of th:
> Note that it's not always possible to make a clean division of cells into headers or data. You should use the TD element for such cells together with the id or scope attributes as appropriate.
(http://www.w3.org/TR/html4/struct/tables.html#h-11.4.1)

Firefox does support this if the header td has a scope attribute, but not if it doesn't. For example, headers aren't associated in this case:
<table>
<tr><td id="h1">h1</td><td id="h2">h2</td></tr>
<tr><td headers="h1">d1</td><td headers="h2">d2</td></tr>
</table>

Arguably, this does conform to the spec. The controversy is in the definition of "as appropriate". You could argue this means that you don't necessarily need to include the scope attribute if it can be inferred or you could argue that "as appropriate" means that you must choose the correct value of scope for your particular case.

A larger test case: http://mars.dequecloud.com/demo/Census_2013.htm
I think we don't do this because we don't have a good idea whether this is row or column headers and thus no idea how to expose them.
(Reporter)

Comment 2

5 years ago
True, though this is the same for th; you still have to guess for a th without a scope attribute.
ok, agree
Blocks: 491681
Should those td have a columnheader/rowheader role in contrast to cell role?
(Reporter)

Comment 5

5 years ago
Personally, I don't mind either way. The fact that they're using td in the first place is a good argument for using the cell role. Personally, I think targeting td elements with a headers attribute is ridiculous, but the spec allows for it.
actually I realized we have a bug 704465
(Reporter)

Comment 7

5 years ago
Should we mark this as a duplicate then?
makes sense
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 704465
You need to log in before you can comment on or make changes to this bug.