[b2g] switch to frame failing after tap

RESOLVED DUPLICATE of bug 779284

Status

RESOLVED DUPLICATE of bug 779284
6 years ago
5 years ago

People

(Reporter: zcampbell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Performing a switch_to_frame after a el.tap() is causing a socket.timeout

I've tried using a time.sleep(5) between the tap which on other occasions has worked but in this case it does not. The test just jams on the switch_to_frame and then times out. 

Replicated both on CI and locally.

The test is test_gallery_delete_image.py and the test steps are here:
https://github.com/mozilla/gaia-ui-tests/blob/master/gaiatest/tests/gallery/test_gallery_delete_image.py#L26

https://github.com/mozilla/gaia-ui-tests/blob/master/gaiatest/apps/gallery/regions/fullscreen_image.py#L56

-----
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/6ca32ed2bbc6
Gaia   8f5ab7bfd4a2921aab4e2de11e0d79a29c1bb062
BuildID 20130529070208
Version 18.0
The cause of this is not obvious, there isn't anything interesting in the logcat. Will need to take time and step through what's going on.
(Reporter)

Comment 3

6 years ago
This has popped up intermittently in another Gallery test. The app source must have changed and exposed us to this again.
This is caused by the modal dialog window popping up and pausing execution of the current frame.

When tap() is called, it dispatches touchstart/touchend events followed by the mousemove/mousedown/mouseup events and then sends a response to the client. Right after touchend is dispatched, the modal dialog window opens and this halts execution of the marionette listener, so it doesn't complete sending the mouse events and the response to the client. If you close the dialog, then execution resumes.

We're working on a solution to this problem in Bug 779284. When that is resolved, this issue should be fixed.
Depends on: 779284
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779284
You need to log in before you can comment on or make changes to this bug.