Purchasing with T-mobile SIM fails with "received bango error"

VERIFIED FIXED in 2013-06-06

Status

Marketplace
Payments/Refunds
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: krupa)

Tracking

2013-06-06
All
Gonk (Firefox OS)
Points:
---

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Country tested from: US
SIM: T-mobile, polish SIM
Env: marketplace-dev

steps to reproduce:
1. Make sure you connected to wifi on your Firefox OS phone
2. Start the purchase of a paid app priced zl0.97
3. Sign in and Enter pin
4. Confirm your phone number and enter Bango PIN
5. Click buy button in Confirm your purchase button

expected behavior:
Purchase is successful

observed behavior:
Purchase fails with "received bango error"

Looks i'm hitting ResponseCode=NOT_SUPPORTED&ResponseMessage=The+user+or+operator+(e.g.+MVNO)+is+not+supported+by+the+biller

GeckoConsole(  108): Content JS LOG at https://marketplace-dev.allizom.org/mozpay/media/js/pay-min.js?build=b0b3f04:6 in callPayFailure: payment failed, closing window
(Assignee)

Comment 1

5 years ago
Created attachment 755661 [details]
http logs

Comment 2

5 years ago
This is a price point issue.

We have the price ppoint of 0.99 but Mozilla are passing 0.97 to us which is causing a mismatch and subsequently a failure.

Comment 3

5 years ago
Just to add that CC wasn't available as it was explicitly excluded by the type filter. 

I'm going to mark as 'Invalid' as this is expected behaviour when we can't support the payment.

Please reopen if you believe the 0.97 PLN price point should be valid.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Assignee)

Comment 4

5 years ago
I am going to close this bug as fixed since the issue report was real and was fixed by changing the pricepoint on mozilla's side.
Assignee: keir → krupa.mozbugs
Resolution: INVALID → FIXED
Target Milestone: --- → 2013-06-06
(Assignee)

Comment 5

5 years ago
we have the right pricepoints now
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.