On desktop, purchase buttons for paid apps should be disabled

VERIFIED FIXED in 2013-06-06

Status

Marketplace
Consumer Pages
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: krupa, Assigned: basta)

Tracking

({regression})

2013-06-06
regression
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 755689 [details]
screenshot

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/app/test-app-price199?src=mkt-detail-upsell in Nightly
2. Notice the purchase button

expected behavior:
purchase buttons are disabled since payments is not supported for desktop

observed behavior:
purchase buttons are enabled
(Assignee)

Updated

5 years ago
Assignee: nobody → mattbasta
Target Milestone: --- → 2013-06-06
(Assignee)

Comment 1

5 years ago
https://github.com/mozilla/fireplace/commit/cadcf99ab6a8fdc9d0174fb811444d9571607770
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 2

4 years ago
Verified as fixed : http://screencast.com/t/oMs9KPj4Lsf
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.