Crash [@ js::frontend::ParseContext<js::frontend::FullParseHandler>::init] with OOM

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 1 bug, {crash, testcase})

Trunk
x86
Linux
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jsbugmon:], crash signature)

(Reporter)

Description

5 years ago
The following testcase crashes on mozilla-central revision 8d85de779506 (no options required):


function inSection(x) {
  return 'a' + x + 'b';
}
oomAfterAllocations(10);
inSection(1);
Function('c');
(Reporter)

Updated

5 years ago
Whiteboard: [jsbugmon:update]
(Reporter)

Updated

5 years ago
Whiteboard: [jsbugmon:update] → [jsbugmon:update,ignore]
(Reporter)

Comment 1

5 years ago
JSBugMon: The testcase found in this bug no longer reproduces (tried revision b7175c5829b5).
(Reporter)

Updated

5 years ago
Whiteboard: [jsbugmon:update,ignore] → [jsbugmon:bisectfix]
(Reporter)

Updated

5 years ago
Whiteboard: [jsbugmon:bisectfix] → [jsbugmon:]
(Reporter)

Comment 2

5 years ago
JSBugMon: Fix Bisection requested, failed due to error (try manually).
(Assignee)

Updated

4 years ago
Assignee: general → nobody
Can't reproduce this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.