[Internal/external memory] view attached image in email does not work when default media location is changed

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

Firefox OS
Gaia::E-Mail
P1
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gecko, Assigned: lightsofapollo)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

(Whiteboard: miniWW)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
1. Step to reproduce
   (a) (setting) Media storage => in Advanced menu, set sdcard as default
   (b) (email) launch email app and sign in
   (c) (email) download an image attachment file, but not view
   (d) (setting) set internal as default
   (e) (email) touch view button to show the previously downloaded image file
2. Symptom : view does not work
3. Expected : view works correctly
4. Frequency Rate : 100%
5. Gaia Revision: 68d645bd416f7f77578258a3ec3e53cb3e8b6d23

There is an another similar issue in notification for image file transfer via bluetooth.
When touch notification, it does not show the image.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+
Whiteboard: miniWW
(Reporter)

Updated

5 years ago
Priority: -- → P1
Target Milestone: --- → 1.1 QE2 (6jun)
Per https://groups.google.com/d/msg/mozilla.dev.b2g/OFJ6eg29QWw/spXMgIR11-EJ we need to use the returned path from the onsuccess method of addNamed and save the path provided there rather than assuming the path we provide (which is just the filename) will remain unchanged.

the files to fix in the back-end are devicestorage-main.js and jobmixins.js (in saveToStorage).  This should be a very straightforward change, although there may be some additional unit test complexity, especially if we want to simulate this particular bug.
Andrew, will you be looking at this or was it james that you suggested would be good to look at this next week?
Flags: needinfo?(bugmail)
(In reply to Wayne Chang [:wchang] from comment #2)
> Andrew, will you be looking at this or was it james that you suggested would
> be good to look at this next week?

I can take a look at it tonight on the plane, but it probably won't get reviewed  by anyone until Monday.

Note that I may have trouble testing on-device because of bug 873247 (I don't have a leo device), but the fix is pretty clear.
Flags: needinfo?(bugmail)
(Assignee)

Updated

5 years ago
Assignee: nobody → jlal
(Assignee)

Comment 4

5 years ago
Created attachment 758250 [details]
GELAM only patch

tested with STR + tests
Attachment #758250 - Flags: review?(bugmail)
(Assignee)

Updated

5 years ago
Attachment #758250 - Attachment mime type: text/plain → text/html
Attachment #758250 - Flags: review?(bugmail) → review+
(Assignee)

Comment 5

5 years ago
in master: https://github.com/mozilla-b2g/gaia/commit/213cab0b3cf05c467f5ffde15da7fcf57cc0a9ed
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 213cab0b3cf05c467f5ffde15da7fcf57cc0a9ed to:
v1-train: c958fbbcf792e515465ec717c6a59288a787428c
status-b2g18: --- → fixed
Followed STR from Comment 0 and expected result is now appearing. 

Environmental Variables
Build ID: 20130806071254
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 4c1a20570e20f64782ba170c14604395c48f7381
Platform Version: 18.1
Firmware Version: D300f08o
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.