App 404 page is very uncool

RESOLVED FIXED in 2013-06-06

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: robhudson, Assigned: spasovski)

Tracking

2013-06-06
x86
Mac OS X
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 755728 [details]
scary 404

Go to an app that you know doesn't exist, like, say: https://marketplace-dev.allizom.org/app/omgwtfbbq

For a 404 page this is very scary looking.

The title says "Loading...".

The ratings API returns a 400 BAD REQUEST but the app API returned a 404. Not sure what that 400 is about.
(Assignee)

Updated

6 years ago
Assignee: nobody → dspasovski
(Assignee)

Comment 1

6 years ago
Coolified! https://github.com/mozilla/fireplace/commit/eb0f551

Bonus points for a sexy 404 graphic to add here.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-06-06
This is/was totally a dupe of bug 870020, which Krupa rightly filed a month ago =)
(Reporter)

Comment 3

6 years ago
(In reply to Christopher Van Wiemeersch [:cvan] from comment #2)
> This is/was totally a dupe of bug 870020, which Krupa rightly filed a month
> ago =)

It's different in a subtle way, at least on the backend. This is from a 404, the other bug is from a 403. Looks way better btw. :)

Comment 4

6 years ago
We should say the page the user was looking for was not found. This page just loads with content missing which is confusing to users.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

6 years ago
Basta fixed the error condition not triggering:

https://github.com/mozilla/fireplace/commit/94db0eb
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.