[Contacts][UX] The warning message of add picture is wrong.

RESOLVED FIXED

Status

Firefox OS
Gaia::Gallery
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: askeing, Assigned: johnhu)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
## STR:
0. Prepare some videos and no photo in Gallery app.
1. Open Contacts app.
2. Add contact.
3. Add Picture > Gallery.
4. Show warning message.

## Actual results:
The warning message title is "No photos or videos".

## Expected results:
The warning message title should be "No photos".
(Reporter)

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: polish

Comment 1

5 years ago
Non-blocking but assigning to Ayman to address in future.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(aymanmaat)

Comment 2

5 years ago
passing to Rob as the message is actually Gallery app side, not contacts app.

needInfo me Rob if you require anything
Flags: needinfo?(aymanmaat) → needinfo?(rmacdonald)
(Reporter)

Comment 3

5 years ago
Change the component
Component: Gaia::Contacts → Gaia::Gallery
Hi David...

Are we able to differentiate the empty state in the Gallery picker if we're filtering for photos only? Sorry for the delay on this one.

- Rob
Flags: needinfo?(rmacdonald) → needinfo?(dflanagan)
Hi Rob,

Yes, we are able to differentiate the empty state when we are in filtering mode. And gallery app only supports photo pick. So, we only need to load different empty message for pick activity.
Flags: needinfo?(dflanagan)
Assignee: nobody → johu
Created attachment 8340990 [details] [review]
use different message title to show the warning message.

use different message title to show the warning message
Attachment #8340990 - Flags: review?(dflanagan)
Created attachment 8340992 [details]
different-warning-title.png

screenshot after this patch is applied.
Created attachment 8340993 [details]
bug877521.zip

Rob, please help to do the ux review. I know this is a small patch. But according to our standard procedures, we need to put ux review when we change something in the UI.
Attachment #8340993 - Flags: ui-review?(rmacdonald)
Comment on attachment 8340993 [details]
bug877521.zip

Hi John...

Although the screenshot that was attached to the bug appears to be correct, the zipped patch continued to state, "No photos or videos".

It could be a problem with the attachment but feel free to flag me to confirm.

Thanks!
Rob
Attachment #8340993 - Flags: ui-review?(rmacdonald) → ui-review-
Created attachment 8342096 [details]
bug877521.zip
Attachment #8340993 - Attachment is obsolete: true
Created attachment 8342097 [details]
correct version
Attachment #8342096 - Attachment is obsolete: true
Comment on attachment 8342097 [details]
correct version

Rob,

Sorry for previous version. I compressed wrong folder. This one is correct. I had double checked. Please review it again.
Attachment #8342097 - Flags: ui-review?(rmacdonald)
Comment on attachment 8340990 [details] [review]
use different message title to show the warning message.

A trivially correct patch.  Simple enough to be completely safe for uplift to 1.3.  But maybe not important enough to bother uplifting.  I'll let UX decide whether to request uplift on this one.
Comment on attachment 8340990 [details] [review]
use different message title to show the warning message.

I did the review but forgot to set the flag.  r+ now.
Attachment #8340990 - Flags: review?(dflanagan) → review+
Comment on attachment 8342097 [details]
correct version

clear ui-review since this is a minor change.
Attachment #8342097 - Flags: ui-review?(rmacdonald)
merged to master:
https://github.com/mozilla-b2g/gaia/commit/a3913b3b4dc1075638181f898da3555b3108a58d
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.