Kinetic scrolling broken in some cases

REOPENED
Unassigned

Status

Firefox OS
General
REOPENED
5 years ago
5 years ago

People

(Reporter: janjongboom, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Running on v1-train when you scroll on the GeeksPhone Keon the scrolling stops abrupt instead of flying if you scroll a bit (but still release it with acceleration). On master it flies nicely all the time, this is highly annoying and breaks desired UX behavior. Can we uplift the changes that made this happen in master to v1-train?
Could this be unique to the Keon?

I can reproduce (intermittently) with 1.0.1 on the Keon (with the latest OTA update) but I can't reproduce on Inari with today's 1.0.1 nightly build or on Leo with 1.1.
Component: Gaia::Browser → General
Keywords: qawanted
Summary: v1-train browser doesn't 'fly' while scrolling → Kinetic scrolling broken in some cases

Comment 2

5 years ago
unable to repro on 
Unagi Build ID: 20130605070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/09dc1ae3b1b5
Gaia: 92a6e36957145cdb2ac8867e5cdba8ecf12308fc

When scrolling on Unagi device there seems to be no issue with this build
Keywords: qawanted

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
I can definitely still reproduce this on a Keon with 1.0.1
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
What is the justification for the tef nomination?

Is this reproduceable on a device other than the Keon?

Comment 5

5 years ago
Moving to leo? since TAs are behind us for 1.0.1 partners and tef? is being shut down.
blocking-b2g: tef? → leo?
Until shown on Leo launch devices, this is not a blocker.
blocking-b2g: leo? → -
You need to log in before you can comment on or make changes to this bug.