Unable to play YouTube video in B2G desktop client

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
P4
normal
RESOLVED WONTFIX
5 years ago
2 months ago

People

(Reporter: davehunt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [platform-rel-Youtube])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I'm unable to play a YouTube video from the Browser app on the B2G desktop client.

Steps to reproduce:
1. Download B2G desktop client from https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly
2. Launch B2G desktop client and dismiss first time usage app
3. Launch Browser app
4. Open http://m.youtube.com/watch?v=5MzuGWFIfio
5. Click play

Expected:
Video app is launched and video content is played

Actual:
It seems a slight flicker occurs, then it appears to be loading something, but then nothing. Subsequent clicks on the play button show the YouTube rating options and the flicker occurs again almost as if it's trying to launch the Video app.

Error console shows the following for each of the clicks:
Error: NS_ERROR_ILLEGAL_VALUE: Illegal value
Source File: http://m.youtube.com/?reload=5&rdm=mnkgk59l#/watch?v=5MzuGWFIfio

I also noticed the following in the console I used to launch the B2G desktop client:
XXX FIXME : Got a mozContentEvent: activity-choice
Which versions of Gecko and Gaia are you using?

When you play the video does it open in a dialog (an inline web activity of the video app) or does it stay on the browser tab (perhaps you could post a screenshot)? It sounds like the web activity isn't working when running in a desktop build.
(Reporter)

Comment 2

5 years ago
I get a different behaviour with a more recent build. Now when I click the play button the screen goes blank swiping up from the bottom. If I then click anywhere on the screen I get the video title and video controls (see screenshot), but no video plays.

Build was downloaded from: https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2013-06-02-23-02-06-mozilla-b2g18/

I'm not sure the best way to get the gecko/gaia revisions for desktop builds. If you can let me know how, I'd be happy to provide these.
(Reporter)

Comment 3

5 years ago
Created attachment 757329 [details]
Screenshot of YouTube video failing to play
This is gecko commit http://hg.mozilla.org/releases/mozilla-b2g18/rev/4785b1353fd7 (from the .txt files in that directory) 

Gaia commit - http://hg.mozilla.org/integration/gaia-v1-train/rev/e26116af80d7 (have to look through the build log in that directory)
Priority: -- → P4
This isnt a Browser bug, it correctly launches the video activity inline to play the video, on a recent desktop build the video app shows a dialog saying the video format is not supported, and in the log I can see video/mp4 as being unsupported, not sure if / how b2g desktop supports mp4 video
Component: Gaia::Browser → Gaia::Video
(Reporter)

Comment 6

5 years ago
Thanks Dale, I see the same behaviour now too. Perhaps this is a current limitation of the B2G desktop build.

Comment 7

5 years ago
Vaguely speaking this bug is still relevant - we still can't play youtube on desktop, but symptoms and expected behaviour have changed for this bug.

The device now plays youtube videos via the HTML5 player in the browser.

The desktop youtube player is still trying to access the rstp/3gp version of the video and failing.

It seems like the desktop b2g browser is not getting the HTML5 player version of Youtube, perhaps because of the UA string?
Switch this bug back to browser app.
Component: Gaia::Video → Gaia::Browser
Component: Gaia::Browser → Video/Audio
Product: Boot2Gecko → Core
(In reply to Zac C (:zac) from comment #7)
> It seems like the desktop b2g browser is not getting the HTML5 player
> version of Youtube, perhaps because of the UA string?

I looked at this, but the UA string of the b2g browser on desktop and device looks almost the same:
http://people.mozilla.org/~mwargers/tests/dom/navigator/navigator_props.htm
https://developer.mozilla.org/en-US/docs/Web/HTTP/Gecko_user_agent_string_reference

Basically, the same situation is happening as what is mentioned at:
https://github.com/webcompat/web-bugs/issues/7
It looks like on the Simulator, you get the behavior like on Android phones, where the Youtube Android app would open.
I don't know how the Youtube site determines that, though.
See also bug 777633 and bug 821513. They might be of interest.
Blocks: 982839
Component: Audio/Video → Audio/Video: Playback

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
Whiteboard: [platform-rel-Youtube]
B2G & 4 years old, changing from P4 (unused by Media Playback team) to P5.
platform-rel: ? → ---
Closing. We're not working on B2G any more, so this is unlikely to addressed.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.