Last Comment Bug 877616 - Attempting to drag a window via the title bar with a Persona enabled doesn't work
: Attempting to drag a window via the title bar with a Persona enabled doesn't ...
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: Thunderbird 24.0
Assigned To: Richard Marti (:Paenglab)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 05:20 PDT by Mark Banner (:standard8, afk until Dec)
Modified: 2013-07-02 06:00 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
+
fixed


Attachments
patch (1.83 KB, patch)
2013-05-30 12:33 PDT, Richard Marti (:Paenglab)
mconley: review+
mconley: ui‑review+
standard8: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Mark Banner (:standard8, afk until Dec) 2013-05-30 05:20:07 PDT
When attempting to drag a window via the title bar, it doesn't work if Persona is enabled. It does work, if you drag via the toolbar.

Also, it does work if personas are disabled.
Comment 1 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-05-30 05:35:56 PDT
This is most likely caused by Bug 676241. This bug added OpenGL context to the titlebar, so we will need to handle dragging ourselves now like Firefox does (and how we handle dragging via the toolbar).

A regression range should be found that verifies that bug is the cause though.
Comment 2 Richard Marti (:Paenglab) 2013-05-30 05:42:44 PDT
Bug 676241 could make sense. As I wrote in bug 876710 it worked for me on 28. But not with the AB and Compozer.
I'll try this today Daily when I'm home. Maybe adding the padding-top to tabs-toolbar instead the window works also here (as a workaround until draw in titlebar lands).
Comment 3 Richard Marti (:Paenglab) 2013-05-30 12:33:36 PDT
Created attachment 756142 [details] [diff] [review]
patch

Adding the padding-top to the tab-toolbar didn't work when mail.tabs.autoHide is true. I added the titlebar vbox now also to OS X like FX is doing. With the same rules as in FX it works now also on TB.
Comment 4 Mike Conley (:mconley) 2013-06-16 13:51:57 PDT
Comment on attachment 756142 [details] [diff] [review]
patch

Review of attachment 756142 [details] [diff] [review]:
-----------------------------------------------------------------

What about the address book and compose windows? Don't we have to worry about those too?
Comment 5 Richard Marti (:Paenglab) 2013-06-16 14:04:59 PDT
This should be done in bug 876710.
Comment 6 Mike Conley (:mconley) 2013-06-16 20:20:21 PDT
Comment on attachment 756142 [details] [diff] [review]
patch

Review of attachment 756142 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, I see - I guess we don't need drag handles on those windows. I remember now.

Ok, yeah this looks fine to me. Thanks Richard!
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-06-18 08:40:08 PDT
https://hg.mozilla.org/comm-central/rev/a6fbfc1ce8c4
Comment 8 Mark Banner (:standard8, afk until Dec) 2013-07-02 05:56:22 PDT
Comment on attachment 756142 [details] [diff] [review]
patch

[Triage Comment]
Leaping this forward onto Beta so we can get it fixed and tested earlier.
Comment 9 Mark Banner (:standard8, afk until Dec) 2013-07-02 06:00:46 PDT
https://hg.mozilla.org/releases/comm-beta/rev/db23b7cc60ef

Note You need to log in before you can comment on or make changes to this bug.