Note: There are a few cases of duplicates in user autocompletion which are being worked on.

[B2G] Leo device displays "Unknown SIM card state", is unable to place calls and can not browse the internet with cellular data.

VERIFIED WORKSFORME

Status

Firefox OS
Gaia
VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: J Zimbrick, Assigned: sku)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [com-ril])

Attachments

(4 attachments, 1 obsolete attachment)

101.28 KB, text/plain
Details
321.01 KB, text/x-log
Details
53.80 KB, image/png
Details
116.74 KB, text/plain
Details
(Reporter)

Description

4 years ago
Description:
 The Leo device displays the SIM card state as unkown, the phone is unable to make calls, and it can not browse the internet via cellular data.

Repro Steps:
1. Update Leo device to build 20130530070208.
2. Open the Settings app and scroll down to the Call Settings and Cellular & Data sections.
3. Observe that "Unknown SIM card State" is displayed under both categories.
4. Open the dialer app, enter a number and attempt to place a call.
5. Observe that nothing happens.
6. Make sure wi-fi is disable and attempt to browse the internet with cellular data.
7. Observe that no connection is made.

Actual:
 Sim card state is unknown, causing the phone to be unable to place calls or browse the internet via cellular data.

Expected:
 The SIM care state will reflect the proper carrier and status of the card currently installed in the device, the phone is able to place calls, and the user is able to browse the internet via cellular data.

Environmental  Variables:

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/09ac1fd2959c
Gaia: 1cca9324d4444ad28c6fa99875e17abf7e8230be

Notes:
Repro frequency: 100% on four devices.
Q Analysts Test Team Priority: Pri 1

Strangely while the phone can not make calls, it is able to receive them, as well as being able to send and receive SMS messages.

This bug appears to be very closely related to an older one; https://bugzilla.mozilla.org/show_bug.cgi?id=859260 , which has consistently failed our smoketest since at 04/12/13.

Updated

4 years ago
blocking-b2g: --- → leo?
Blocks: 876999

Comment 1

4 years ago
Can you please provide the logcat log?

Comment 2

4 years ago
Created attachment 756819 [details]
logcat
This should block, but will wait for Leo triage to make call.
Starting today, the Leo commercial and mozilla RIL cannot receive phone calls.

Build ID: 20130604070205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/997cdbf5d012
Gaia: 5534304aee934055f08f21ce93261ba2a596516a
Version: 18.0
Also seen on the Unagi commercial RIL.

Build ID: 20130604070205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/997cdbf5d012
Gaia: 5534304aee934055f08f21ce93261ba2a596516a
Version: 18.0
Summary: [B2G][Leo] Leo device displays "Unknown SIM card state", is unable to place calls and can not browse the internet with cellular data. → [B2G] Leo device displays "Unknown SIM card state", is unable to place calls and can not browse the internet with cellular data.

Comment 6

4 years ago
Ken - would you mind taking a look now that we have logs? This is a smoketest issue, so it should be prioritized over other 1.1 work.
Assignee: nobody → kchang
blocking-b2g: leo? → leo+

Comment 7

4 years ago
The log is for commercial RIL, and it doesn't show obvious error related to SIM card.

Could anyone provide log with Mozilla RIL?

Comment 8

4 years ago
Created attachment 758413 [details]
logcat file

(In reply to Shian-Yow Wu from comment #7)
> The log is for commercial RIL, and it doesn't show obvious error related to
> SIM card.
> 
> Could anyone provide log with Mozilla RIL?

I can reproduce this issue. The message showed fail in Solicited response of REQUEST_GET_SIM_STATUS. the error code was 1. 

I/Gecko   (  134): RIL Worker: Solicited response for request type 1, token 4, error 1
I/Gecko   (  134): RIL Worker: Handling parcel as REQUEST_GET_SIM_STATUS

The radio log only showed 

responseSimStatus: A RilCardStatus_v6 or _v5 expected

Comment 9

4 years ago
Per Vincent and Yoshi, this should be same root cause as bug 872992.

The current leo/hamachi v1-train manifest points to "b2g/ics_strawberry".  If that caused the mismatch issue with RIL, can we change it to "ics_chocolate_rb4.2" which used by otoro/unagi/inari?
Assignee: kchang → vliu
Flags: needinfo?(jhford)

Comment 10

4 years ago
(In reply to Shian-Yow Wu from comment #9)
> Per Vincent and Yoshi, this should be same root cause as bug 872992.
> 
> The current leo/hamachi v1-train manifest points to "b2g/ics_strawberry". 
> If that caused the mismatch issue with RIL, can we change it to
> "ics_chocolate_rb4.2" which used by otoro/unagi/inari?

The base versions are currently correctly matched. Inari uses ics_chocolate_rb4.2, leo uses b2g/ics_strawberry, and hamachi uses b2g/ics_strawberry_v1.

If things are still incompatible, we can put their RILs in extract-files.sh.
Flags: needinfo?(jhford)
Also seen on the Buri commercial RIL.

Build ID: 20130610070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8e3f39363c54
Gaia: ce3b99781d182ad550a325206990c249b0dbcf0e
Version: 18.0

Comment 12

4 years ago
:jhford had some modification in manifest for leo on bug 872992 so I set depend on it.


https://bugzilla.mozilla.org/show_bug.cgi?id=872992#c6
Depends on: 872992

Comment 13

4 years ago
Sync with today's build and can't reproduce this issue any more. I will close this bug. Please re-open it if anyone has new found.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Verifying as Worksforme on Leo 1.1 commercial RIL.  The SIM card can be seen and the related functions work properly.

Build ID: 20130625070217
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
Gaia: 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Platform Version: 18.1
Status: RESOLVED → VERIFIED

Comment 15

4 years ago
This is still broken on hamachi, as of Build ID: 20130907220211

I know this issue is about Leo not Hamachi, but supposedly the underlying cause is the same.

Comment 16

4 years ago
More info on the build in which the issue is still present on hamachi:

Gaia: a6a0fb84927299cdc2a0bd913b7fee8993727236
Gecko: 700373b45b3478fcabcd3361871956ca76b2b0fa
Platform Version: 18.1

Comment 17

4 years ago
Seems to be still broken in v1-train on hamachi. The device shows: (unknown SIM state) 

Build info:
Gaia: 6324c3b047aabee83ec7419803224e8edf07db7c
Gecko: 700373b45b3478fcabcd3361871956ca76b2b0fa
Platform Version: 18.1

Configured with: BRANCH=v1-train ./config.sh hamachi

Comment 18

4 years ago
Created attachment 801872 [details]
hamachi.png

Added screenshot from the actual device showing the problem..

Comment 19

4 years ago
Created attachment 801874 [details]
logcat-hamachi

Attached logcat from hamachi, which unfortunately does not show any obvious problems related to RIL.

Comment 20

4 years ago
> adb logcat -b radio 
E/RILD    (  148): **RIL Daemon Started**
E/RILD    (  148): **RILd param count=1**
E/RILD    (  148): RIL_Init argc = 4 client = 0
E/RILPROXY(  145): Could not connect to rild socket, retrying: Connection refused
W/RILC    (  148): RIL_onUnsolicitedSendResponse called before RIL_register
E/RILC    (  148): isMultiSimEnabled: prop_val = 0 enabled = 0
E/RILC    (  148): RIL_register: RIL version 6
E/RILC    (  148): s_registerCalled = 1, s_started = 1, RIL_getMaxNumClients = 1
E/RILC    (  148): isMultiSimEnabled: prop_val = 0 enabled = 0
E/RILC    (  148): responseSimStatus: A RilCardStatus_v6 or _v5 expected

Comment 21

4 years ago
Switched to Shawn Ku to handle the following tracking.
Assignee: vliu → sku
(Assignee)

Updated

4 years ago
Flags: needinfo?(jarek)
(Assignee)

Comment 22

4 years ago
Hi Jarek:
 It looks like RIL log in gecko is disabled.

Please follow below steps to enable it first. and get log for us to check again.

1. make sure RIL debug configuration is enabled.
  1.1 adb pull /system/b2g/defaults/pref/user.js /tmp
  1.2 Modify the value of ril.debugging.enabled to true.
      pref("ril.debugging.enabled", true);
  1.3 adb remount
  1.4 adb push /tmp/user.js /system/b2g/defaults/pref/
  1.5 adb reboot


adb logcat command:
adb logcat -b main -b radio -v threadtime > c:/temp/877757.log


Thanks!!
sku
(Assignee)

Updated

4 years ago
Whiteboard: [com-ril]
The libril is mis-matched, i.e. this build uses a wrong revision of libril.
Flags: needinfo?(jarek)

Comment 24

4 years ago
Hi Shawn,
Unfortunately the device is a retail version of OneTouch Fire from T-Mobile, so it's not rooted, and therefore I cannot modify user.js on the device:

~>adb remount
remount failed: Operation not permitted
~>adb root
adbd cannot run as root in production builds

BTW I'm happy to root the device, but unfortunately I could not find any info and/or flashable images that would allow it.

Comment 25

4 years ago
Created attachment 803257 [details]
hamachi-ril.log

Attached is the logcat file with RIL log enabled, as requested by Shawn
Attachment #801874 - Attachment is obsolete: true

Comment 26

4 years ago
Just for the record, I enabled RIL debugging in a slightly different way:

adb pull /system/b2g/defaults/pref/user.js /tmp
# Modified the value of ril.debugging.enabled to true.
adb push /tmp/user.js /sdcard/user.js
adb shell
shell@android:/ $ su
shell@android:/ # mount -o rw,remount -t yaffs2 /dev/block/mtdblock1 /system 
shell@android:/ # cat /sdcard/user.js > /system/b2g/defaults/pref/user.js      
adb reboot

logcat obtained with "adb logcat -b main -b radio -v threadtime" attached.
(Assignee)

Comment 27

4 years ago
Hi Jarek:
 May we have more detail about how you get this device?
As you said, this is a retail version of OneTouch Fire from T-Mobile. however, it looks like we got some issue on libril (see comment 23).

if this is a retail version, we should have a bunch of similiar issue reported, not just this one. 


06-02 17:36:18.519   148   148 E RILC    : RIL_register: RIL version 6
06-02 17:36:22.249   144   258 I Gecko   : RIL Worker: Handling parcel as UNSOLICITED_RESPONSE_SIM_STATUS_CHANGED
06-02 17:36:22.259   148   227 E RILC    : responseSimStatus: A RilCardStatus_v6 or _v5 expected
06-02 17:36:22.379   148   227 E RILC    : responseSimStatus: A RilCardStatus_v6 or _v5 expected

thanks!!
sku
Flags: needinfo?(jarek)

Comment 28

4 years ago
Hi Shawn,

This is a retail version of OneTouch Fire from T-Mobile, updated to the latest v1-train, built from the source code. The exact commands used to to update the phone were:

BRANCH=v1-train ./config.sh hamachi 
./build.sh clean 
./build.sh 
./flash.sh 

See comment #17 for the version number. What other info do you need?
Flags: needinfo?(jarek)

Comment 29

4 years ago
Shawn,

I'm not the only one reporting this issue. Here's a post from another person with the same device, reporting the same problem after upgrade.

http://www.mail-archive.com/dev-b2g@lists.mozilla.org/msg03964.html

Please let me know what info you need.
(Assignee)

Comment 30

4 years ago
Hi Jarek:
 Since this commercial RIL, we need to file a SR for proper people to check this issue then.
Thanks for your support!!

Hi Wayne:
 Could you please ask partner to file a SR for tracking why we got such issue on commercial RIL?

Thanks!!
sku
Flags: needinfo?(wchang)

Comment 31

4 years ago
Shawn,

Not sure if it's relevant, but I think /system/bin/rild and /system/lib/libril*.so on the phone got replaced during flash. I compared rild and libril*.so in the backup-hamachi directory created by ./config.sh, and they are different from what has been flashed to the device by ./flash.sh. That leads me to believe, that RIL currently on my device is not the same RIL that was originally shipped with the device.

(If this piece of info is useless or obvious, just disregard it).

Thank you.
(Assignee)

Comment 32

4 years ago
Hi Jarek:
 Please make sure the SW is the shipped one before reproducing this issue.
(not replacing any rild/libril*.so)
We need to know if the shipped SW has this problem or not.

Thanks!!
sku
(Assignee)

Updated

4 years ago
Flags: needinfo?(wchang)

Comment 33

4 years ago
Shawn:
As reported by users - evertyhing works OK on production firmware. Problem exists only after flashing images built from mozilla B2G repo (with BRANCH=v1-train). Alcatel obviously modified their tree when building their firmware and because of that, hamachi device from mozilla's B2B repo is not fully compatible with Alcatel OTF phone.

Comment 34

4 years ago
As explained above, the issue is not about the software shipped by Alcatel/T-Mobile. The problem appears after flashing the device with FirefoxOS built from v1-train.

Apparently flash.sh replaces not only gecko and gaia, but rild, libril and some other binaries on the system partition as well.

Comment 35

4 years ago
I have the same problem, my phone is Alcatel OTF / Movistar, I did

BRANCH=v1-train 
./config.sh hamachi 
./build.sh 
./flash.sh 
 
And whatever SIM I put I get "Unknown SIM card State", Alcatel provide a link to source 
http://sourceforge.net/projects/alcatel/files/ONE_TOUCH_FIRE_4012_20130628.tar.xz/download
but I don't know how use it, then i use what I think is the source oficial (stable)

What is the solution?

Comment 36

4 years ago
Hi Shawn,
As another user confirmed the problem (see above), would it be possible to at least acknowledge that there is a bug by re-opening this issue?

With the current state of the v1-train branch, any owner of the retail version of Alcatel OTF who follows the instructions publicly available on developer.mozilla.org will end up with a non-working phone, so this may escalate pretty quickly.

Comment 37

4 years ago
Rod2012, 

Could you please take a look at https://bugzilla.mozilla.org/show_bug.cgi?id=917559 and check if this fixes the problem for you? It did for Jarek :)

Comment 38

4 years ago
Thanks you for guide me, I am going
You need to log in before you can comment on or make changes to this bug.